0

Ajenti Downloads PHP files instead of executing them

Tyler Sowers 5 years ago updated by Casper Smits 4 years ago 4
Server: Ubuntu 14.04.2
Ajenti Version: Latest

Ajenti continues to download PHP files and not execute them. Here is a screenshot of my configuration

Here is the generated config file:



#AUTOMATICALLY GENERATED - DO NO EDIT!






server {
listen *:80;








access_log /var/log/nginx/domain.access.log;
error_log /var/log/nginx/domain.error.log;


root /var/www/GEM;
index index.html index.htm index.php;










location ~ [^/]\.php(/|$) {






fastcgi_index index.php;
include fcgi.conf;
fastcgi_pass unix:/var/run/ajenti-v-php-fcgi-domain-php-fcgi-0.sock;
fastcgi_param SCRIPT_FILENAME $document_root$fastcgi_script_name;


}


}


Any ideas?
Any solutions to this problem yet ?
see your nginx logs
and post it here

and check your nginx service is runnig or not

What nginx logs would you like to see? I'm having nothing in my rainloop.access.log or rainloop.error.log...


Edit: I did have something in my logs when I made a typo (on purpose); I tried accessing domain.com/Aindex.php
Error log: 2015/11/16 14:36:46 [error] 13972#0: *5 FastCGI sent in stderr: "Primary script unknown" while reading response header from upstream, client: my_ip_adress, server: my.domain.nl, request: "GET /aindex.ph$

Access log: my_ip_adress - - [16/Nov/2015:14:36:46 +0100] "GET /aindex.php HTTP/1.1" 404 47 "-" "Mozilla/5.0 (Windows NT 10.0; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/46.0.2490.86 Safari/537.36"



Edit: a server restart and clearing browser cache worked (incognito mode)