FTP connection issue.

Fedor Bakl 10 лет назад обновлен 10 лет назад 9
Using Ajenti V on Ubuntu 12.04. Trying to connect with username and password from "websites->ftp" section using website's domain getting:

Connection timed out or server hung up. The server you are connecting to may be configured to limit the number of connections you are allowed to make.

Nothing logged into vsftpd logs. I can connect using my normal ubuntu user and sftp. Would appreciate help!
Oh and when i am trying to update Ajenti V i get

Exception AttributeError: AttributeError("'Event' object has no attribute '_reset_internal_locks'",) in 

yc'> ignored                                                                                                                                                    

Reading package lists... Done                                                                                                                                   

Building dependency tree                                                                                                                                        

Reading state information... Done                                                                                                                               

The following packages will be upgraded:                                                                                                                        


1 upgraded, 0 newly installed, 0 to remove and 11 not upgraded.                                                                                                 

Need to get 2,552 B of archives.                                                                                                                                

After this operation, 0 B of additional disk space will be used.                                                                                                

Get:1 http://repo.ajenti.org/debian/ main/main ajenti-v-ftp-vsftpd all 0.2.2 [2,552 B]                                                                          

Fetched 2,552 B in 0s (16.9 kB/s)                                                                                                                               

Failed to fetch http://repo.ajenti.org/debian/pool/main/a/ajenti-v-ftp-vsftpd/ajenti-v-ftp-vsftpd_0.2.2_all.deb  Hash Sum mismatch                              

E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?                                                                           

 * Process has exited with status 25600

На рассмотрении
It just means that your package lists are out of sync

E: Unable to fetch some archives, maybe run apt-get update
Please check whether vsftpd is running with a) service vsftpd status and b) ps aux | grep vsftpd
I did run the update i little after i posted the issue and after that ajenti updated just fine.

As regarding vsftpd the service is not running. I tried service vsftpd start and i got:
start-stop-daemon: unable to open pidfile '/var/run/vsftpd/vsftpd.pid' for writing (Permission denied)

Permissions were for root:root and rwx-r-r, so i tried rwx-rwx-r -  didn;t not work, as i could not find the correct user to set permissions for this file i used 777 just to test. After doing service vsftpd start i got this:
Starting FTP server: vsftpd.

then i did ps aux | grep vsftpd got the following:
root 1198 0.0 0.0 23456 436 ? Ss Apr20 0:00 /usr/sbin/vsftpd
fedor 11531 0.0 0.1 9368 912 pts/0 S+ 11:55 0:00 grep --color=auto vsftpd

After i checked the vsftpd was not running, would really appreciate some help. Thanks.

I am running Ubuntu 12.04, could not find any info on SELinux on ubuntu.

Сервис поддержки клиентов работает на платформе UserEcho