+8

Installation Issue - The following packages have unmet dependencies: ???

Aaron Esteban 3 lat temu Ostatnio zmodyfikowane przez Luciano de Almeida Silva 2 miesięcy temu 3

I am trying to install Ajenti on a new Digital Ocean Droplet with Linux Ubuntu (20.something). And while running the command line installation.....

Quick automatic install

wget -O- https://raw.github.com/ajenti/ajenti/1.x/scripts/install-ubuntu.sh | sudo sh

I keep getting some issues with installing the required Python packages. Here's the message that I keep getting:

The following packages have unmet dependencies:
 ajenti : Depends: python (>= 2.6)
          Depends: python-support (>= 0.90.0) but it is not going to be installed
          Depends: python-lxml (>= 2.2.4) but it is not going to be installed
          Depends: python-gevent but it is not going to be installed
          Depends: python-gevent-socketio but it is not going to be installed
          Depends: python-psutil (>= 0.6.0) but it is not going to be installed
          Depends: python-reconfigure (>= 0.1.46) but it is not going to be installed
          Depends: python-daemon but it is not installable
          Depends: python-passlib but it is not going to be installed
          Depends: python-requests (>= 0.12.0) but it is not going to be installed
          Depends: python-dbus but it is not going to be installed
          Depends: python-imaging but it is not installable
          Depends: python-catcher but it is not going to be installed
          Depends: python-exconsole (>= 0.1.5) but it is not going to be installed
          Depends: python-ldap but it is not installable
E: Unable to correct problems, you have held broken packages.

What exactly do I need to do to correct this problem and ensure that I have a solid installation? Thanks.

Same problem on Debian 11.
After half a day's work I managed to work out this solution:

sudo apt update
sudo apt install -y build-essential
sudo apt install -y python
sudo apt install -y python-dev libldap2-dev libsasl2-dev ldap-utils tox lcov valgrind


python get-pip.py
pip install ajenti


sudo apt install -y curl
curl https://bootstrap.pypa.io/pip/2.7/get-pip.py -o get-pip.py

sudo apt -y install gnupg2
wget http://repo.ajenti.org/debian/key -O- | sudo apt-key add -
echo "deb http://repo.ajenti.org/debian main main debian" | sudo tee /etc/apt/sources.list.d/ajenti.list

sudo apt update
sudo apt download ajenti
sudo dpkg -i --force-depends ajenti_1.2.23.13_all.deb


Problem after installing ajenti like this is that `apt` thinks it is now holding broken dependencies. It always asks you to run `apt --fix-broken install`, which would then uninstall ajenti again.

Hey

I have the same problem

root@file:/home/ti# apt-get install ajenti -y
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
ajenti : Depends: python (>= 2.6) but it is not installable
Depends: python-support (>= 0.90.0) but it is not going to be installed
Depends: python-lxml (>= 2.2.4) but it is not installable
Depends: python-gevent but it is not going to be installed
Depends: python-gevent-socketio but it is not going to be installed
Depends: python-psutil (>= 0.6.0) but it is not going to be installed
Depends: python-reconfigure (>= 0.1.46) but it is not going to be installed
Depends: python-daemon but it is not installable
Depends: python-passlib but it is not going to be installed
Depends: python-requests (>= 0.12.0) but it is not going to be installed
Depends: python-dbus but it is not installable
Depends: python-imaging but it is not installable
Depends: python-catcher but it is not going to be installed
Depends: python-exconsole (>= 0.1.5) but it is not going to be installed
Depends: python-ldap but it is not installable
E: Unable to correct problems, you have held broken packages.

I tried the above procedure and it didn't work.


Some help?