MySQL error 2002 Can't connect to local MySQL server through socket'/...

abagshaw 9 years ago updated by Lexy 9 years ago 1
I've been getting this error ever since installing Ajenti on a clean install of CentOS 6 x64. I just installed phpMyAdmin as per the tutorial on Ajenti's fourms. However I can't log into phpMyAdmin and whenever I try to chage my password through the MySQL plugin it says "Saved. Please restart Ajenti for changes to take affect".

However each time I open the MySQL plugin I get that error (written in the subject). I tried uninstalling the MySQL Ajenti V package - then installing it again. Still no luck.
first of all you should remove mariadb, becaz ajenti dosnt support maria db
then you shoud install mysql-server
you cant use yum install mysql , becaz no longer centos support MySQL, and install mariadb instaed
you shoud install mysql-server like this
yum instal mysql-server
then config mysql
sudo /usr/bin/mysql_secure_installation
when you run this code , ask you couple question abour securing mysql, you shoud config root user and set password

install and enable mysql
sudo yum install mysql-server 
sudo service mysqld start
go to ajenti , select mysql from software section ,and enter your data like this
host: or localhost
username: root
password: your password

restart ajenti , and done

sorry for my bad english, be happy