0
Answered

PHP FastCGI not listed in content type after downgrading PHP 5.5

meme 6 years ago updated by Eugene Pankov (Project coordinator) 6 years ago 4
My Setup: Ubuntu 14.04, Ajenti v1.2.22.16 with Ajenti V.

when installed its running PHP 5.5 as default. I've to use php 5.4 for my websites. 
I downgraded successfully and restarted the ajenti, nginx and php-fpm successfully.

Sites are running well. However when I tried to add/edit new websites, there is no PHP FastCGI option in content type dropdown in Contant tab of the websites.

Tried to look for errors/ there's no error at all..

so any pointers to fix this? 
GOOD, I'M SATISFIED
Satisfaction mark by meme 6 years ago
Under review
See if the PHP plugin got loaded in the Plugins page. Click on it to see what prevented it from loading.
Found the issue (i think).

What I did was only restarting php-fpm, nginx and ajenti using 'service xxx restart' command.

when i do complete stop of php-fpm & nginx using 'service xxx stop' and login to ajenti panel, click on restart ajenti followed by restarting the websites this fixed the issue. seems weird though but at least it fixed it.

thanks eugene for the review.