0

RainLoop how to let users change their password

David Oster 4 years ago • updated by Alexandre Martins 5 months ago 12

I have installed a new hosting server under https://e.eletter.gr:8000.

I started giving email access to the users via an email client called RainLoop under webmail.their_domain

But I seem I can't find a way to let them change their own account's email password.


How could this be achieved?

I think writing a script where it changes the /etc/ajenti/mail.json is a bit dangerous.

Any suggestions?


Preferably I would like to give access within RainLoop to change their password.

RainLoop does not support this functionality yet at least!

yes please inform me if there updated plugin for rainloop

I managed to fix it by installing courierpassd and the poppassd-change-password plugin of rainloop.

Hi David, can you help with how you configured courierpassd please?

I've installed courierpassd and as well enabled the poppassd plugin on Rainloop.

But it's throwing error while changing password.


Thanks

@CreativeWolf, you also need to go to the services file, e.g. /etc/services and replace the lines that poppassd uses with these using the port 106 on TCP/UDP protocols):

(with # is considered a comment, the original lines from poppassd)

#poppassd 106/tcp # Eudora
#poppassd 106/udp
courierpassd 106/tcp
courierpassd 106/udp


Then do a restart to make sure that all services have being running properly.

Still getting the same error "Could not save new password"

@David Thank you, just did that and restarted the box. All the services are running fine but I don't see anything listening on port 106. Although typing in courierpassd in the prompt gives "200 courierpassd v1.1.2 hello, who are you?" Not sure, what else I'm missing. Appreciate any help.

Did you try via rainloop to change the password and to see if it works?

@David Yes, I tried to change and this is the message I get - "Could not save new password"

Did anyone make any progress on this? I've tried a few different things but it all comes right back to the error code 130 - COuld not save new password.


{"Action":"ChangePassword","Result":false,"ErrorCode":130,"ErrorMessage":"","ErrorMessageAdditional":"","Time":1018}

I would like to believe that either Rainloop or poppassd so not have write access whatever password file it's reading from. Any thoughts on this?

How did you do it? I followed the David Oster steps by i couldn't make it work.