How to add Munin as a website to Nginx using Ajenti V

Bruno 9 years ago updated by Eugene Pankov (Project coordinator) 9 years ago 6
I want to have Munin as a website managed by Ajenti V running on http://domain/munin with basic authentication plus local only access, but i can't figure it out on how to do it, i can only seem to get it to work under http://domain/ but not http://domain/munin/ can someone please giveme some help on this?
Under review
You're probably running into path appending behavior of NGINX. If your URL pattern is "/munin" and munin files are in /usr/share/munin, your location path should be "/usr/share" since NGINX appends sub-URL to the path (see more in NGINX's "root" directive docs)
hm, don't think its about that... its more about adding an alias and forget the root like this:

location /munin/ {
alias /var/cache/munin/www/;

is there any gui tool to add this per website? if i add this lines to the website custom configuration, it will work as http://domain/munin/ but will also work as http://domain/ (root) no intended to! sorry for the lack of knowledge, don't know if i made me understand well
I'll be adding alias support in the nearest V release, in the meantime you can add "alias ...;" to custom configuration of your /munin location (location > advanced > custom config).
Nice, i'll wait then! this is great for multiple sites with only one domain (not really the ajenti V focus). like having http://mydomain.com/munin and http://mydomain.com/owncloud 
New V packages released, adding "Append URL pattern to path" option, which enables use of root instead of alias (on by default for new websites, off for old ones).