+2
Under review

Ajenti panel fails to load (Ubuntu 14.04 x64).

blackalis 6 years ago updated by jcdevaux 6 years ago 6
Trying a fresh install of Ajenti on a fresh Ubuntu 14.04 x64 VPS from DigitalOcean.

Ran the install as per the automatic install described here. That went all nice and smooth, and when I visit the Ajenti URL, it presents me with the login prompt and accepts the default credentials.

However, it then never progresses past the "spinning gears" page (similar what was posted here). This occurs in both Chrome and Safari.

Running as $ ajenti-panel -v and hitting Ctrl+\ at the appropriate time produces:

Traceback (most recent call last):
File "/usr/lib/python2.7/dist-packages/gevent/greenlet.py", line 327, in run
result = self._run(*self.args, **self.kwargs)
File "/usr/lib/python2.7/dist-packages/gevent/server.py", line 103, in wrap_socket_and_handle
return self.handle(ssl_socket, address)
File "/usr/lib/pymodules/python2.7/socketio/server.py", line 70, in handle
handler.handle()
File "/usr/lib/python2.7/dist-packages/gevent/pywsgi.py", line 184, in handle
result = self.handle_one_request()
File "/usr/lib/python2.7/dist-packages/gevent/pywsgi.py", line 321, in handle_one_request
self.handle_one_response()
File "/usr/lib/pymodules/python2.7/socketio/handler.py", line 123, in handle_one_response
jobs = self.transport.connect(socket, request_method)
File "/usr/lib/pymodules/python2.7/socketio/transports.py", line 138, in connect
self.write("1::") # 'connect' packet
File "/usr/lib/pymodules/python2.7/socketio/transports.py", line 22, in write
if 'Content-Length' not in self.handler.response_headers_list:
AttributeError: 'SocketIOHandler' object has no attribute 'response_headers_list'
<Greenlet at 0x7f487294d370: <bound method SocketIOServer.wrap_socket_and_handle of <SocketIOServer at 0x7f4873c780d0 fileno=5 address=0.0.0.0:
8000>>(<socket at 0x7f4873cc9790 fileno=-1>, ('xxx.xxx.xxx.xxx', 55280))> failed with AttributeError
^\
Activating emergency console
----------------------------
Caused by:
Signal SIGQUIT
Stack frames:
> [ 0] /usr/lib/python2.7/dist-packages/gevent/hub.py:364
loop.run()
On frame 0
Source:
def run(self):
assert self is getcurrent(), 'Do not call Hub.run() directly'
while True:
loop = self.loop
loop.error_handler = self
try:
>> loop.run()
finally:
loop.error_handler = None # break the refcount cycle
self.parent.throw(LoopExit('This operation would block forever'))
Press Ctrl-D to leave console
Type "_help()" for built-in commands
>>>
I've tried disabling SSL, same error. I've uninstalled Ajenti and Python, still same error. Short of blatting the entire server and starting fresh with a different OS, I'm not sure what else to do.

Any assistance would be appreciated. Thanks!
Under review
Please upload output of apt-show-versions somewhere, it's likely incompatible versions of python-gevent-websocket and python-gevent-socketio
+1
Please try downgrading python-gevent-websocket. 
Hi !

Same issue for me. Don't know if you managed to solve it ? 
I've tried to downgrade websocket to 0.3.6-1 as in ajenti repository.
Stil the same error message and still waiting for the pannel...

python-gevent-socketio is now 0.3.5-rc2-1.
python-gevent-websocket was 0.9.3-1 and is now 0.3.6-1.

Server using Ubuntu 14.04 LTS 64 bits, Linux 2.6.32-042stab084.14, Ajenti 1.2.21.13 and Ajenti V 0.2.32.
Client using Ubuntu 13.3 64 bits, Linux 3.8.0-35-generic, Chromium browser 31.0.1650.63 or Firefox 26.0.
Just to be clear, did you restart Ajenti after package downgrade?
Yes sure. I've used "ajenti-panel -v" for that test.
Ctrl+C then downgrade and again "ajenti-panel -v" to restart the test.