0
Z odpowiedzią

Ajenti apache and reverse proxy ( 0.99.33 )

Sébastien Andreatta 7 lat temu Ostatnio zmodyfikowane przez Eugene Pankov (Project coordinator) 6 lat temu 5

I'm trying to install Ajenti from repository on CentOs 6.4 ( 0.99.33 ) i can't use reverse proxy .

Here is how i install it :


wget http://repo.ajenti.org/ajenti-repo-1.0-1.noarch.rpm
rpm -i ajenti-repo-1.0-1.noarch.rpm
yum -y install ajenti

service ajenti restart

Reverse proxy configuration :

ProxyPass /ajenti http://localhost:8000
ProxyPassMatch ^/(ajenti.*)$ http://localhost:8000/$1
ProxyPassReverse /ajenti:static/ http://localhost:8000/ajenti:static/
ProxyPassReverse /ajenti:auth http://localhost:8000/ajenti:auth
ProxyPassReverse /ajenti http://localhost:8000

With this configuration i can go to : https://server/ajenti/ but i can't loggin, on subtmit i'm redirected to https://server/ .

The form action is set to : "/ajenti:auth" but i'm redirected to "/" 
Were is the trick ? 
Thanks

Odpowiedź

Odpowiedź
Ajenti issues a redirect to /, you need to rewrite it to /ajenti/

UPDATE: now included in the guide: http://support.ajenti.org/topic/472359-ajenti-behind-apache/ 
Odpowiedź
Ajenti issues a redirect to /, you need to rewrite it to /ajenti/

UPDATE: now included in the guide: http://support.ajenti.org/topic/472359-ajenti-behind-apache/ 
+1
How would that work with Apache? And why are these redirects necessary? The login / logout problem is not documented in any of the docs I've found...

If all URLs are prefixed with ajenti, why can the redirect not point to /ajenti?
W trakcie analizy
It totally makes sense to do the root redirects, as / is the entry point of this web-application. I've updated the page with a working redirect-rewriting config:  http://support.ajenti.org/topic/472359-ajenti-behind-apache/

There is no way to add a configuration option to tell to ajenti what subdirectory to use ?

Because the link from Ajenti wiki doesn't work, and the code in plugins/main/main.py is static...

What i don't understand is : with Ajenti 0.99.2 I hasn't have this error


Thanks for your help