Under review


felipe rce 11 years ago updated by anonymous 7 years ago 7

Hello, I sucess installed ajenti, but when I access the plugin menu, he show many plugins witch "Dependency Unsatisfied", apache, mysql, bind9 dhcpserver, and others...

Apache, mysql and bind already installed and working great!

But this plugins not show in ajenti menu!

Ubuntu server 12.04

If you expand the plugin list item, you can see exact list of dependencies and which application binaries are required. Then you can check if each one is accessible by running `which <app name>`

Hi there,

I know this post is quite old, but I am also confused.

I have installed Apache, and can see httpd is running, but the Apache plugin has a triangle exclamation mark next to it, with the message "Application binary" depends on "httpd".

There doesn't seem to be a clear way to fix this dependency. I'm sure it must be something obvious, unfortunately I don't understand the previous reply:

Then you can check if each one is accessible by running `which <app name>`

Where do we need to run this? 

I installed Apache with the Ajenti "packages" installer.

I can see that on certain plugins, like CTDB, there is a little download button to install the dependency directly, so I'm guessing the fact this download option doesn't exist for Apache, it can't be downloaded from there.

I have installed Ajenti in a Centos 6.5 environment, and can access the Apache 2 success page when viewing the website address, so this error is confusing..

Can anyone offer a bit of insight?
Under review

You need to simply run the command in terminal, and it will show whether the binary exists, and if so, where.
Ahh, hang on. I seem to have solved the problem by restarting the service and restarting Ajenti. Great, I am beginning to really like this little panel, very nice.
Thank you, the point is that the binary already existed, so the problem was that one needs to restart the services for Ajenti to pick it up..
Thanks a lot for this awesome panel!
Sorry I understand nothing about dependency :s
1- I tried it for bind9, so I checked depends on; and there is ! named, so I typed "which named" in my ssh and the answer is no named in(usr/local/bin:/sbin...

2- if it had been found, what would I have to do with that? 

Thanks in advance!
If you need BIND9 plugin to work, install the BIND9 application itself (I assume that you're on CentOS: yum install bind, or install bind from the Packages page). Then restart Ajenti and plugin should be available.