0
Not a bug

Switching to system user db leaves them without rights to plugins.

Andrius Kačergius 6 ár síðan updated by Erix Molinie 6 ár síðan 6
Therefore "no plugins are allowed for this user" is thrown. config.json has no commented out/suggested way to add modules into, leaving system inaccessible. 
Under review
After enabling OS user sync, log in to the panel as root user, and assign permissions to the users in Configuration section.
+1
Problem with that is, my servers intentionally have no root password setup for security reasons, using sudo as means to elevate. I did purge/reinstall, and it's fine now, but what threw me off was that green thingie to the right asking to restart ajenti, where now i first assigned permissions to system users before restarting.
I see; In case of emergency you can disable authentication in config.json file and fix the settings as Ajenti's root user. However locking yourself out of root account in Ajenti isn't a way to go :)
+10
This is sort of inconvenient. The default setup for Ubuntu Server is to have the root user disabled, and I've never had any reason to change that on any of my servers.

The first thing I did after installing Ajenti was go to change the default account password. I saw the sync with OS users option and set that. That's how I ended up here five minutes after install. It may not be a bug but it's definitely not the best user experience. I feel maybe a warning to Ubuntu users when switching to this options would be nice.
+8
Hi,
I agree with you, this must be changed in Ajenti not on the Ubuntu side.
Regards
Erix