+4
Answered

Install Ajenti 1.0 beta on Ubuntu 10.04 Lucid

Marcio Merlone 7 years ago updated by Eurico Vidal 5 years ago 12

I am trying to install ajenti on a ubuntu lucid server, but seems to have some kirk about python version:


root@venus:~# aptitude install ajenti

Lendo listas de pacotes... Pronto

Construindo árvore de dependências      

Lendo informação de estado... Pronto

Lendo informações estendidas de estado      

Inicializando estados de pacotes... Pronto

Os pacotes a seguir estão QUEBRADOS:

  python-passlib python-requests python-urllib3 

Os NOVOS pacotes a seguir serão instalados:

  ajenti python-chardet{a} python-daemon{a} python-gevent{a} python-gevent-socketio{a} python-gevent-websocket{a} python-greenlet{a} python-imaging{a} python-lockfile{a} python-lxml{a} python-psutil{a} python-reconfigure{a} stunnel{a} 

  stunnel4{a} 

0 pacotes atualizados, 17 novos instalados, 0 a serem removidos e 3 não atualizados.

É preciso obter 3475kB de arquivos. Depois do desempacotamento, 12,6MB serão usados.

Os pacotes a seguir possuem dependências não satisfeitas:

  python-passlib: Depende: python (>= 2.7.1-0ubuntu2) mas 2.6.5-0ubuntu2~lts2 está instalado.

  python-urllib3: Depende: python (>= 2.7.1-0ubuntu2) mas 2.6.5-0ubuntu2~lts2 está instalado.

                  Depende: python-six o qual é um pacote virtual.

  python-requests: Depende: python (>= 2.7.1-0ubuntu2) mas 2.6.5-0ubuntu2~lts2 está instalado.

                   Depende: python-six o qual é um pacote virtual.

As seguintes ações resolverão estas dependências:

Manter os pacotes a seguir em suas versões atuais:

ajenti [Não Instalado]

python-passlib [Não Instalado]

python-requests [Não Instalado]

python-urllib3 [Não Instalado]

Pontuação é -9852

Aceitar esta solução? [Y/n/q/?] q

Abandonando todos os esforços para resolver estas dependências.

Abortar.

root@venus:~# dpkg -l | grep python

(...)

ii  python2.7                                   2.7.3-2+lucid1


Any workaround?

Answer

Hi,


Thank you for your feedback. No luck. I had not python-urllib3, python-passlib, python-requests installed and made no difference.

Ajenti only depends on python-requests, and right now ajenti repo contains python-requests from debian-squeeze-backports, which doesn't depend on py2.7 or urllib3 or six: http://packages.debian.org/squeeze-backports/python-requests


I am having a similar issue;

Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 ajenti : Depends: python-requests but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
root@lagrange:~# apt-get install python-requests
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 python-requests : Depends: python2.6 but it is not installable
  Depends: python (< 2.7) but 2.7.3-0ubuntu2.2 is to be installed
  Recommends: python-gevent but it is not going to be installed
  Recommends: python-oauthlib but it is not installable
E: Unable to correct problems, you have held broken packages.
root@lagrange:~# apt-get install python
Reading package lists... Done
Building dependency tree
Reading state information... Done
python is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
root@lagrange:~# python-requests

Fresh Ubuntu 12.4.2 LTS Server install

Any suggestions


Not yet:


root@venus:~# aptitude update

(...)

Lendo listas de pacotes... Pronto

root@venus:~# aptitude install ajenti

Lendo listas de pacotes... Pronto

Construindo árvore de dependências      

Lendo informação de estado... Pronto

Lendo informações estendidas de estado      

Inicializando estados de pacotes... Pronto

Os pacotes a seguir estão QUEBRADOS:

  ajenti 

Os NOVOS pacotes a seguir serão instalados:

  python-daemon{a} python-gevent{a} python-gevent-socketio{a} python-gevent-websocket{a} python-greenlet{a} python-imaging{a} python-lockfile{a} python-lxml{a} python-passlib{a} python-psutil{a} python-reconfigure{a} stunnel{a} stunnel4{a} 

0 pacotes atualizados, 14 novos instalados, 0 a serem removidos e 24 não atualizados.

É preciso obter 3291kB de arquivos. Depois do desempacotamento, 11,9MB serão usados.

Os pacotes a seguir possuem dependências não satisfeitas:

  ajenti: Depende: python-requests o qual é um pacote virtual.

As seguintes ações resolverão estas dependências:

Manter os pacotes a seguir em suas versões atuais:

ajenti [Não Instalado]

Pontuação é -9881

Aceitar esta solução? [Y/n/q/?] q

Abandonando todos os esforços para resolver estas dependências.

Abortar.

root@venus:~# 


I'm having the similar issue =/

I try install ajenti and receive the error, you can help me with this?


Unfortunately 10.04 isn't supported (as said on the download page), but you still can install Ajenti through PIP and it will work:

sudo apt-get install python-pip libxml2-dev libxslt-dev libmysqlclient-dev (please check exact pkg names on 10.04)
sudo pip install --upgrade ajenti
I'm trying install on the same server that was installed proxmox, I can do it?
I try using PIP but I cant access on port 8000, I need do more something?
sorry, I'm check and when I try install by PIP was returned a error http://pastie.org/9566599
when I try install "pip install -U cryptography" has returned the same error =/

You know if is possible to use proxmox and after install ajenti?
ops, they want remove my proxmox =/ I give up hehe in the next time I will install the Ajenti before the Proxmox, maybe it's work hehe

thanks for all ;)