0
Respuestas

How do I add domain names?

Ee Eer hace 6 años actualizado por Christophe Blaszkowski hace 5 años 8
How do I add domain names to Ajenti V?
I have two "website" things setup.
I pointed my domain using A name to the IP address of the server.

The domain takes me to the site that's "Default" rather than the site that I want.
How do I access an individual "Site" ?
I can only access "Default"

This is on a VPS
Of course it's added under the "Domains" tab of the "Website" entity under "Web" under "Website" in Ajenti V
En revisión
That should be sufficient. Are you sure that DNS propagation timeout has already passed? Also please post both domain names and either screenshot of your website domains tab or /etc/ajenti/vh.json file.
It's working now. I don't know exactly what made it work. I just started flipping checkboxes on and off, restarting websites, enabling/disabling in different orders and the domains eventually point to the right Site.
Most probably, you didn't wait for your zone changes to propagate, and now it completed itself :)
I do not see option to add domain, web, website etc!!! I'm with the installed panel and can not put my site up because I do not see option add domain! of all panels that have already installed this is the most different!
I have the same problem.
I've installed a wordpress on one website and a pydio on another website. As soon as I enable the Pydio site, the wordpress domain points to the pydio instead.
It's done two days ago so there was enough time for DNS propagation timeout to be passing.

I've tried it with several wordpress websites too. Strange thing is most of the times it shows the correct websites but sometimes default website which is very annoying.

I wonder if any one can give me some help?
Here is my /etc/ajenti/vh.json file:



{
"websites": [
{


"maintenance_mode": false,
"locations": [
{
"custom_conf_override": false,
"path_append_pattern": false,
"pattern": "[^/]\\.php(/|$)",
"custom_conf": "# Zero-day exploit defense.\n# http://forum.nginx.org/read.php?2,88845,page=3\n# Won't work properly (404 error) if the file is not stored on this server, which is entirely possible with php-fpm/php-fcgi.\n# Comment the 'try_files' line out if you set up php-fpm/php-fcgi on another machine. And then cross your fingers that you won't get hacked.\ntry_files $uri =404;\nfastcgi_split_path_info ^(.+\\.php)(/.+)$;",
"path": "",
"match": "regex",
"backend": {
"params": {
"php_admin_values": "open_basedir = none;",
"php_flags": "",
"pm": "dynamic"
},
"type": "php-fcgi"
}
}
],
"custom_conf": "",
"ssl_key_path": "/etc/ssl/pydio_key.pem",
"owner": "root",
"ssl_cert_path": "/etc/ssl/pydio_cert.pem",
"custom_conf_toplevel": "",
"name": "pydio",
"enabled": false,
"extensions": {
"ajenti.plugins.vh.processes.ProcessesExtension": {
"processes": []
},
"ajenti.plugins.vh-vsftpd.vsftpd.VSFTPDExtension": {
"username": "pydio",
"password": "Something",
"user": null,
"created": true
},
"ajenti.plugins.vh-mysql.mysql.MySQLExtension": {
"users": [
{
"password": "Something",
"name": "pydio"
}
],
"databases": [
{
"name": "DB2"
}
]
}
},
"domains": [
{
"domain": "DOMAIN 2"
}
],
"root": "/srv/pydio",
"ports": [
{
"spdy": false,
"ssl": false,
"host": "*",
"port": 80,
"default": false
},
{
"spdy": false,
"ssl": true,
"host": "*",
"port": 443,
"default": false
}
]
},
{
"maintenance_mode": false,
"locations": [
{
"custom_conf_override": false,
"path_append_pattern": false,
"pattern": "[^/]\\.php(/|$)",
"custom_conf": "# Zero-day exploit defense.\n# http://forum.nginx.org/read.php?2,88845,page=3\n# Won't work properly (404 error) if the file is not stored on this server, which is entirely possible with php-fpm/php-fcgi.\n# Comment the 'try_files' line out if you set up php-fpm/php-fcgi on another machine. And then cross your fingers that you won't get hacked.\ntry_files $uri =404;\nfastcgi_split_path_info ^(.+\\.php)(/.+)$;",
"path": "",
"match": "regex",
"backend": {
"params": {
"pm": "dynamic",
"php_admin_values": "open_basedir = none;",
"php_flags": ""
},
"type": "php-fcgi"
}
}
],
"custom_conf": "# Allow file upload to 100MB.\n# Default size is 2MB which is very small for most of images and files.\nclient_max_body_size 100M;\n\n# This order might seem weird - this is attempted to match last if rules below fail.\nlocation / {\n\ttry_files $uri $uri/ /index.php?$args;\n}\n\n# Add trailing slash to */wp-admin requests.\nrewrite /wp-admin$ $scheme://$host$uri/ permanent;\n\n# Directives to send expires headers and turn off 404 error logging.\nlocation ~* ^.+\\.(ogg|ogv|svg|svgz|eot|otf|woff|mp4|ttf|rss|atom|jpg|jpeg|gif|png|ico|zip|tgz|gz|rar|bz2|doc|xls|exe|ppt|tar|mid|midi|wav|bmp|rtf)$ {\n access_log off; log_not_found off; expires max;\n}\n\nlocation = /favicon.ico {\n\tlog_not_found off;\n\taccess_log off;\n}\nlocation = /robots.txt {\n\tallow all;\n\tlog_not_found off;\n\taccess_log off;\n}\n\n# Deny all attempts to access hidden files such as .htaccess, .htpasswd, .DS_Store (Mac).\n# Keep logging the requests to parse later (or to pass to firewall utilities such as fail2ban)\nlocation ~ /\\. {\n\tdeny all;\n}\n# Deny access to any files with a .php extension in the uploads directory\n# Works in sub-directory installs and also in multisite network\n# Keep logging the requests to parse later (or to pass to firewall utilities such as fail2ban)\nlocation ~* /(?:uploads|files)/.*\\.php$ {\n\tdeny all;\n}",
"ssl_key_path": "/etc/ssl/Domain1_key.pem",
"owner": "root",
"ssl_cert_path": "/etc/ssl/Domain1_cert.pem",
"custom_conf_toplevel": "",
"name": "DOMAIN 1",
"enabled": true,
"extensions": {
"ajenti.plugins.vh.processes.ProcessesExtension": {
"processes": []
},
"ajenti.plugins.vh-vsftpd.vsftpd.VSFTPDExtension": {
"username": "username1",
"password": "Something",
"user": null,
"created": true
},
"ajenti.plugins.vh-mysql.mysql.MySQLExtension": {
"users": [
{
"password": "Something",
"name": "username1"
}
],
"databases": [
{
"name": "DB1"
}
]
}
},
"domains": [
{
"domain": "DOMAIN 1"
}
],
"root": "/srv/Domain1",
"ports": [
{
"spdy": false,
"ssl": false,
"host": "*",
"port": 80,
"default": false
},
{
"spdy": false,
"ssl": true,
"host": "*",
"port": 443,
"default": false
}
]
}
]
}
same problem for me
I change the windows hosts file to review the correct ip address but the first site is still considered by default.

Thank you in advance for your assistance