+1
Not a bug

Ajenti not restarting successfully with NGINX running?

Lucas Gomez 7 years ago updated by Станислав Буценко 6 years ago 9

Hi again,


I'm currently running Ajenti on Debian Wheezy, clean install, after installing NGINX without starting, Ajenti will restart successfully, login screen and everything. But if you start NGINX and restart Ajenti, Ajenti won't come back up. Is there some type of conflict with Ajenti? What I have to do to allow Ajenti to start is stop NGINX. Is this as designed or a bug?


By the way, Ajenti is running on 8000, while NGINX on 80. This was a clean Ajenti install and right away NGINX without any modifications.

Can you try to run Ajenti in foreground while NGINX is working?


ajenti-panel -v

That worked. I guess the issue is on the web restart when NGINX is running?

So `ajenti-panel -v` works with running NGINX, but `service ajenti start` doesn't, am I right?

I get error:
2014-10-10 15:21:46,605 INFO registry.register_crypt_handler(): registered crypt handler 'sha512_crypt': <class 'passlib.handlers.sha2_crypt.sha512_crypt'>
2014-10-10 15:21:46,715 INFO core.run(): Ajenti 1.2.22.13 running on platform: debian
2014-10-10 15:21:47,212 WARNING __init__.load(): *** [elements] Plugin error: format error
2014-10-10 15:21:47,486 INFO core.run(): Starting server on (u'127.0.0.1', u'8008')
2014-10-10 15:21:47,497 ERROR core.run(): Could not bind to (u'127.0.0.1', u'8008')
2014-10-10 15:21:47,497 ERROR : Could not bind to (u'127.0.0.1', u'8008')
This means that some other process has taken the port 8008 
But I checked all open ports: `sudo nmap -sT -O localhost`. Here are all open ports:
```
80/tcp open http
139/tcp open netbios-ssn
443/tcp open https
445/tcp open microsoft-ds
631/tcp open ipp
```
P.S. OS Ubuntu 14.04 x64