0

Can't install Ajenti on Ubuntu 12.04 LTS​

kwmt27 5 year бұрын 0
Can't install Ajenti on Ubuntu 12.04 LTS
# apt-get update && apt-get install ajenti
Hit http://repo.ajenti.org main InRelease
Hit http://repo.ajenti.org main InRelease
Hit http://repo.ajenti.org main/main amd64 Packages                                                                      
Ign http://archive.ubuntu.com precise InRelease                                                 
Hit http://repo.ajenti.org main/debian amd64 Packages
Hit http://repo.ajenti.org main/main i386 Packages
Hit http://repo.ajenti.org main/debian i386 Packages
Hit http://repo.ajenti.org main/main amd64 Packages
Hit http://repo.ajenti.org main/ubuntu amd64 Packages
Hit http://repo.ajenti.org main/main i386 Packages
Hit http://repo.ajenti.org main/ubuntu i386 Packages                 
Ign http://ppa.launchpad.net precise InRelease                       
Hit http://archive.ubuntu.com precise Release.gpg
Hit http://archive.ubuntu.com precise Release
Hit http://ppa.launchpad.net precise Release.gpg
Hit http://archive.ubuntu.com precise/main amd64 Packages
Hit http://ppa.launchpad.net precise Release
Hit http://archive.ubuntu.com precise/universe amd64 Packages
Hit http://archive.ubuntu.com precise/main i386 Packages
Hit http://archive.ubuntu.com precise/universe i386 Packages
Hit http://ppa.launchpad.net precise/main Sources
Hit http://ppa.launchpad.net precise/main amd64 Packages
Hit http://ppa.launchpad.net precise/main i386 Packages
Reading package lists... Done
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 ajenti : Depends: python-gevent-socketio but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
# 
# pip list               
apt-xapian-index (0.44)
chardet (2.0.1)
defer (1.0.2)
Warning: cannot find svn location for distribute===0.6.24dev-r0
distribute (0.6.24dev-r0)
gevent (0.13.6)
gevent-socketio (0.3.6)
gevent-websocket (0.9.5)
GnuPGInterface (0.3.2)
greenlet (0.4.0)
Mako (1.0.2)
MarkupSafe (0.23)
meld3 (1.0.0)
pip (7.1.2)
pycurl (7.19.0)
python-apt (0.8.3ubuntu7)
python-catcher (0.1.7)
python-debian (0.1.21ubuntu1)
requests (2.7.0)
setuptools (0.6rc11)
supervisor (3.0)
unattended-upgrades (0.1)
# 
# cat /etc/lsb-release
DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=12.04
DISTRIB_CODENAME=precise
DISTRIB_DESCRIPTION="Ubuntu 12.04 LTS"
#