0
Answered

How can I access an email account?

Sorin Gitlan 6 years ago updated by an solas 6 years ago 27
I have created an email address test@example.com using the Mailbox button
but I can't manage to configure the account in Thunderbird.
It doesn't find any configuration automatically and I tested all the variants there and fail..

The forwarding service works so there should be no issue with exim (I hope).

So.. what is the default generated configuration for a new email account?



Answer

Answer
Answered
Username: test@example.com
Password: your password
SMTP server: server's address
IMAP server: server's address
Ports: default ones (SMTP TLS and IMAPS if you have configured TLS for Ajenti V mail).
GOOD, I'M SATISFIED
Excellent!
Satisfaction mark by Sorin Gitlan 6 years ago
Answer
Answered
Username: test@example.com
Password: your password
SMTP server: server's address
IMAP server: server's address
Ports: default ones (SMTP TLS and IMAPS if you have configured TLS for Ajenti V mail).
Still doesn't work.

Thunderbird gets this configuration by probing the server:

IMAP, hostname: domain.info, Port: 143, SSL: STARTTLS, Auth: Normal Password
SMTP, hostname: domain.info, Port: 25, SSL: None, Auth: Normal Password


But when I click on "Done" I get error: "Configuration could not be verified - is the username or password wrong?"
I've tried everything. Removed and recreated the account, changed password, no password, username with and without the @domain... 
Do I need to do anything else to activate the account?

I'm on: Debian GNU/Linux 7.5 (wheezy)



Check /var/log/exim/ and /var/log/mail for authentication errors. Are you sure that Thunderbird doesn't strip @ and domain part from the username?
in /var/log/mail
imapd: Connection, and 
imapd: Disconnected, ip=[::ffff: .. logs

in /var/log/exim4/mainlog I only get this message when I do the probe for configuration:
SMTP protocol synchronization error (next input sent too soon: pipelining was not advertised): rejected "EHLO we-guess.mozilla.org" H=[xx:xx:xx:xx] next input="QUIT\r\n"

I don't think so.. I already have an account configured on another server (with Virtualmin) and the username is the email and it works.. 
It appears to be a bug in Thunderbird's setup wizard: https://bugzilla.mozilla.org/show_bug.cgi?id=53880... - however actual mail processing in TB isn't affected
Is it possible to skip the verification?
Yeah I can bypass that wizard.. but still won't fetch the email.. It hangs with a message "Checking mail server capabilities..."

I will download some other email clients.. and test to see if it works.

For POP3 access I need to do something different? For example to add the account in the Gmail app.

Thank you very much for your time in helping with this issues!!

UPDATE: tried with Opera mail .. still can't access the mailbox.
It receives mail but can't access it :)
You can get POP3 access by installing respective courier-pop package for your OS. Could you please check the logs while Thunderbird is fetching mail? That would really help.
OK so I've installed courier-pop (on debian 7) and in thunderbird I choose POP3 for incoming 
but I used another server for SMTP and it worked. Thunderbird fetched the emails.
If I use the current server hostname still won't work.

So maybe there is something setup wrong in SMTP...

Some Logs:

~ tail -f mainlog
exim 4.80 daemon started: pid=3293, -q30m, listening for SMTP on port 25 (IPv4) port 465 (IPv4)

~ tail -f mail.log
imapd: Connection, ip=[::ffff:------------]
imapd: Disconnected, ip=[::ffff:------------], time=0



Could it be that you are using IPv6 only on your network? It seems that it was used to connect to IMAP server (although that might be an 6to4 address, I'm not a specialist at ipv6), while Exim is listening at IPv4 only.
Any idea where to force exim to use ipv4?
I searched for some info and made changes but still nothing..
I've uploaded an ajent-v-mail update which will enable IPv4 and IPv6 in Exim at once - please try.
So is your network IPv6-enabled? Are you entering an IPv6 address or a domain that has an AAAA record as a SMTP server address?
I have updated ajenti mail

I have no AAAA record, just an MX record.
Ajenti was installed on a fresh Debian7 installation and no changes to IP were made.

Now I get "email@example.com Unrouteable address" in mailog when I send an email to the account.  


So SMTP is working now? Can you please post complete block of exim log for this email (example: https://gist.github.com/Eugeny/cd5af6ee8f8162dd5c07)? I presume email@example.com is an existing configured mailbox in Ajenti V Mail?
I've made the upgrade then deleted the old emails and created 2 new email.. One mailbox sorin@example.com 
and one for forwarding  sorin2@example.com..

Both fail with message: 
The error that the other server returned was:
550 Unrouteable address

2014-05-26 18:07:44 1WozJI-0001zj-Nl <= email@gmail.com H=(mail-ve0-f172.google.com) [209.85.128.172] P=esmtp S=1755 id=CAC+UjKiNsdA-cBWQYZuX5jFp8M3WwhHvVqx9=i7frFb3vNBW0Q@mail.gmail.com
2014-05-26 18:07:44 1WozJI-0001zj-Nl ** sorin@email.info: Unrouteable address
2014-05-26 18:07:44 1WozJI-0001zm-SI <= <> R=1WozJI-0001zj-Nl U=Debian-exim P=local S=2544
2014-05-26 18:07:44 1WozJI-0001zj-Nl Completed
2014-05-26 18:07:45 1WozJI-0001zm-SI => email@gmail.com R=dnslookup T=remote_smtp H=gmail-smtp-in.l.google.com [74.125.136.26] X=TLS1.2:RSA_ARCFOUR_SHA1:128
2014-05-26 18:07:45 1WozJI-0001zm-SI Completed


(I will edit later to remove the actual emails)

Update: edited emails
Could you please zip all /etc/exim* directories together and mail them to e@ajenti.org?
I've sent an email with the attachemnts!
Currently I could add the account in Thunderbird.. it connected successfully but fails with "Unable to open this mailbox".
I can send emails. I tested with: echo "test mail." | mail -s Test email@example.com

But any email sent to the email box on this server fails with the error above "Unroutable address".
I didn't get this before the update.. Maybe I still need to configure something more...

Thank you!

I've found something:

The results for this:  exim -d -bt sorin@esgy.info


>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>
Testing sorin@esgy.info
>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>
Considering sorin@esgy.info
>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>
routing sorin@esgy.info
--------> vforward router <--------
local_part=sorin domain=esgy.info
checking domains
esgy.info in "esgy.info : localhost"? yes (matched "esgy.info")
esgy.info in "+local_domains"? yes (matched "+local_domains")
R: vforward for sorin@esgy.info
calling vforward router
rda_interpret (file): /etc/exim.forward/$local_part@$domain
expanded: /etc/exim.forward/sorin@esgy.info
/etc/exim.forward/sorin@esgy.info does not exist
checking parent directory
stat(/etc/exim.forward/.)=0
/etc/exim.forward/sorin@esgy.info does not exist
vforward router declined for sorin@esgy.info
"more" is false: skipping remaining routers
no more routers
sorin@esgy.info is undeliverable: Unrouteable address
search_tidyup called
>>>>>>>>>>>>>>>> Exim pid=13867 terminating with rc=2 >>>>>>>>>>>>>>>>


I have only a mailbox: sorin@esgy.info
I can't add a forward with the same address. I tried but it fails.

I added a forward mailobx and tested it with: exim -d -bt sorin2@esgy.info

>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>
Testing sorin2@esgy.info
>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>
Considering sorin2@esgy.info
>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>
routing sorin2@esgy.info
--------> vforward router <--------
local_part=sorin2 domain=esgy.info
checking domains
esgy.info in "esgy.info : localhost"? yes (matched "esgy.info")
esgy.info in "+local_domains"? yes (matched "+local_domains")
R: vforward for sorin2@esgy.info
calling vforward router
rda_interpret (file): /etc/exim.forward/$local_part@$domain
expanded: /etc/exim.forward/sorin2@esgy.info
20 bytes read from /etc/exim.forward/sorin2@esgy.info
file is not a filter file
parse_forward_list: forapathy@gmail.com,
extract item: forapathy@gmail.com
vforward router generated forapathy@gmail.com
errors_to=NULL transport=NULL
uid=unset gid=unset home=NULL
routed by vforward router
envelope to: sorin2@esgy.info
transport: <none>
>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>
Considering forapathy@gmail.com
>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>
routing forapathy@gmail.com
.......



Hope it helps....
Thank you for testing! It was the problem with when forwarding doesn't exist, local delivery wasn't considered... update released!
I have manually created a forward email for the mailbox sorin@esgy.info .. with forward to gmail and it worked..
But accessing it through IMAP with thunderbid still doesn't work.
I've also downloaded Thunderbird 31 and both IMAPS and SMTP+STARTTLS seem to work well
Yeah.. Everything seems to work OK.
Until you get a first mail the when Thunderbird accesses the account it gives an error.. but then after it works.

Thank you very much for all your help with this issue!
Hello,
I am trying to access a IMAP Mailbox with apple Mail, but when I try to connect I get :
"The server returned the error: Unable to open this mailbox."

Any Ideas what could be wrong, please?

In connection doctor I see that teh coinnection was successfull
The exim main log says :
input sent without waiting for greeting

[Fixed] by sending myself an email.
Just added a second account, rebooted the server and now its broken again ?!
The main exim log says:
2014-07-08 07:27:10 plain authenticator failed for (daslichts-pro.multi.box) [<<snip>>]: 435 Unable to authenticate at present (set_id=<<snip>>): failed to connect to socket /var/run/courier/authdaemon/socket: Permission denied
...
root@h2318011:~# ls -l /var/run/courier/authdaemon/socket
srwxrwxrwx 1 root root 0 Jul 8 07:23 /var/run/courier/authdaemon/socket

[EDIT]
The /var/run/courier/authdaemon had the wrong permissions.

This helped me:
https://lists.debian.org/debian-user/2006/12/msg00636.html
+1
After restarting the srever the permissions are broken again ?!