0
Fixed

CentOS and Ajenti 1.0.1

InteractMarketing 7 years ago updated by Maftei Alexandru 6 years ago 23

Trying to upgrade to 1.0.1 but instructions doesn't work (CentOS). Returns Package ajenti-0.6.2-1.noarch already installed and latest version. Uninstalled and try again directions from the main page - no luck.


Any clue?


Thanks

Answer

Answer
Fixed

Try following:

yum clean all

yum install ajenti

Well - still can't get this to work


Resolving Dependencies
--> Running transaction check
---> Package ajenti.noarch 0:0.99.5-1 will be installed
--> Processing Dependency: reconfigure >= 0.1.17 for package: ajenti-0.99.5-1.noarch
--> Processing Dependency: python-imaging for package: ajenti-0.99.5-1.noarch
--> Processing Dependency: python-gevent-socketio for package: ajenti-0.99.5-1.noarch
--> Processing Dependency: python-requests for package: ajenti-0.99.5-1.noarch
--> Processing Dependency: python-gevent-websocket for package: ajenti-0.99.5-1.noarch
--> Processing Dependency: python-daemon for package: ajenti-0.99.5-1.noarch
--> Processing Dependency: python-passlib for package: ajenti-0.99.5-1.noarch
--> Processing Dependency: python-psutil for package: ajenti-0.99.5-1.noarch
--> Processing Dependency: stunnel for package: ajenti-0.99.5-1.noarch
--> Running transaction check
---> Package ajenti.noarch 0:0.99.5-1 will be installed
--> Processing Dependency: python-daemon for package: ajenti-0.99.5-1.noarch
--> Processing Dependency: python-passlib for package: ajenti-0.99.5-1.noarch
---> Package python-gevent-socketio.noarch 0:0.3.5_rc2-1 will be installed
---> Package python-gevent-websocket.noarch 0:0.3.6-1 will be installed
---> Package python-imaging.x86_64 0:1.1.6-19.el6 will be installed
---> Package python-psutil.x86_64 0:0.6.1-1 will be installed
---> Package python-requests.noarch 0:1.1.0-1 will be installed
---> Package reconfigure.noarch 0:0.1.17-1 will be installed
---> Package stunnel.x86_64 0:4.29-3.el6_4 will be installed
--> Finished Dependency Resolution
Error: Package: ajenti-0.99.5-1.noarch (ajenti)
  Requires: python-daemon
Error: Package: ajenti-0.99.5-1.noarch (ajenti)
  Requires: python-passlib

I have just been updating the repository - please try again!

Well. still errors using new and old method to install Ajenti on CentOS

Yes - EPEL was required in previous release, and I forgot to mention it now :)

Got it installed, but the browser is stuck on a screen with spinning wheels.

sudo service ajenti stop

ajenti-panel -v


You will see error messages if there are any problems.

Got bunch of warnings on [xyz] Plugin crashed: crashed: No module named xyz and also that:



Traceback (most recent call last):
  File "/usr/lib64/python2.6/site-packages/gevent/greenlet.py", line 328, in run
  result = self._run(*self.args, **self.kwargs)
  File "/usr/lib/python2.6/site-packages/socketio/virtsocket.py", line 358, in _receiver_loop
  retval = pkt_ns.process_packet(pkt)
  File "/usr/lib/python2.6/site-packages/socketio/namespace.py", line 155, in process_packet
  return self.call_method_with_acl('recv_connect', packet)
  File "/usr/lib/python2.6/site-packages/socketio/namespace.py", line 221, in call_method_with_acl
  return self.call_method(method_name, packet, *args)
  File "/usr/lib/python2.6/site-packages/socketio/namespace.py", line 253, in call_method
  return method(*args)
  File "/usr/lib/python2.6/site-packages/ajenti/api/http.py", line 88, in recv_connect
  self.emit('auth-error', '')
  File "/usr/lib/python2.6/site-packages/socketio/namespace.py", line 427, in emit
  self.socket.send_packet(pkt)
  File "/usr/lib/python2.6/site-packages/socketio/virtsocket.py", line 299, in send_packet
  self.put_client_msg(packet.encode(pkt))
  File "/usr/lib/python2.6/site-packages/socketio/packet.py", line 82, in encode
  payload = json.dumps(d, separators=(',', ':'), **json_decimal_args)
  File "/usr/lib64/python2.6/site-packages/simplejson/__init__.py", line 237, in dumps
  **kw).encode(obj)
TypeError: __init__() got an unexpected keyword argument 'use_decimal'
<Greenlet at 0x13a9cd0: <bound method Socket._receiver_loop of <socketio.virtsocket.Socket object at 0x14ddc50>>> failed with TypeError

Also

service ajenti restart
Stopping Ajenti:
not running  [FAILED]
Starting Ajenti:
started  [  OK  ]

and then

service ajenti restart
Stopping Ajenti:
not running  [FAILED]
Starting Ajenti:
started  [  OK  ]

It says started but comes as not running.

This is due to outdated python-simplejson. I have uploaded simplejson-3.3.0 to the repository.

Should I uninstall and try to install it now?

You can either uninstall simplejson, or upgrade it to our newer version. Then simply restart Ajenti

Well, installed new simplejson and still getting those spinning wheels :\

Got panel to work but with HTTP connection not HTTPS. Any clue?

And now I'm getting this:


wget http://repo.ajenti.org/ajenti-repo-1.0-1.noarch.rpm
rpm -i ajenti-repo-1.0-1.noarch.rpm



--> package ajenti-repo-1.0-1.noarch is already installed
yum clean all yum install ajenti --> No package ajenti available
Looks like is something missing for CentOS installation or directions are not good.

Well, it looks like CentOS version is not even 1.0 but 0.99

That's right, beta builds are all numbered 0.99.x. Have you succeeded running it yet? Can I provide any help?

I was be able to update to 0.99.6 and today to 0.99.7. Also I have reported issues with iptables part and Apache part here: http://ajenti.userecho.com/topic/196997-ajenti-099-6-on-centos-64/

Answer
Fixed

Try following:

yum clean all

yum install ajenti