0
Answered

Install ajenti on remote vps

6 years ago updated by Eugene Pankov (Project coordinator) 6 years ago 14
Hello. I have pourchased a remote vps server. It has debian, so I copied the command on this site to install ajenti.
After installation, it is suposed to be on https://<hostname>:8000. I tried to replace hostname with the ip or the domain name and I don't get nothing.
Is it really posible to install on remote vps?
Under review
Yes, it's definitely possible. Have you seen any error messages during installation? If you don't remember, it's safe to run install again.
well, I've seen it use ngnix, but it has apache installed. Could it be a problem?
This would be a problem if your Apache configuration already uses port 8000 for itself.
I've uninstalled apache and restarted the server. It didn't work. 
The page (firefox) shows the following error: The connection to the server was reset while the page was loading.
Can you verify that no firewall or NAT is blocking the port 8000?
Well, I try to contact with host company. By the way, It is possible to change the port of ajenty via commands?
Yes, you can edit the /etc/ajenti/config.json file and replace the port value.

Here are two quick diagnostic steps you can take:
1) check Ajenti startup: run service ajenti stop; ajenti-panel -v. You'll get some output if Ajenti starts normally. While it runs, you can go on and try open the panel page in the browser.
2) check network connectivity: run apt-get install netcat; nc -l 8000. Then try to open http://<ip>:8000. If the connectivity is ok, you'll see browser request in the nc output.
Well, I haven't get any success with netcat, neither on my local machine or the remote one I have got it working.
I've reinstalled all and I get this exit with ajenti-panel:
http://pastebin.com/tycd6WHH
Even with this error, the ajenti server keeps on because it shows an exit when I try to connect through my web browser and the console shows this output:

http://pastebin.com/TGPqJgeH
SSL23_GET_CLIENT_HELLO:http error usually means HTTP:// and HTTPS:// are messed up in the URL.
Hum... That's true...
I've tried with https and it worked
but...
When I load ajenti-panel, I think the daemon doesn't start succesfully, because the ajenti server works while the console command is running. It never ends (waits for input). The traceback error it shows is the following:

Traceback (most recent call last):
File "/usr/lib/pymodules/python2.7/gevent/greenlet.py", line 390, in run
result = self._run(*self.args, **self.kwargs)
File "/usr/lib/pymodules/python2.7/ajenti/feedback.py", line 52, in worker
resp = send('register', data)
File "/usr/lib/pymodules/python2.7/ajenti/feedback.py", line 36, in send
return json.loads(response.content)
File "/usr/lib/python2.7/json/__init__.py", line 326, in loads
return _default_decoder.decode(s)
File "/usr/lib/python2.7/json/decoder.py", line 365, in decode
obj, end = self.raw_decode(s, idx=_w(s, 0).end())
File "/usr/lib/python2.7/json/decoder.py", line 383, in raw_decode
raise ValueError("No JSON object could be decoded")
ValueError: No JSON object could be decoded
<Greenlet at 0x1b39c30: worker> failed with ValueError

PD: I've found how get the ajenti daemon: ajenti-panel -d. But, anyway, this could be a bug which must be solved?
Answered
No, that's ok. If you run without -d, Ajenti continues to work, attached to the console. -d runs it the same way, except it detaches from the console. The right way is to run service ajenti start (which will run service with -d and track it).
The error message you see comes from the update server, it doesn't affect functionality of your panel.
So, ¿the valueError exception is ok?
Yes, it's OK. I'm fixing the error message on server-side now anyway.