0
Answered

Installing and Running Ajenti on ReadyNAS RN102

Arpan Jain 5 years ago updated by Eugene Pankov (Project coordinator) 5 years ago 5
Hi,

I want to install Ajenti on Netgear ReadyNAS 102. I was able to successfully install it but I am not able to access it using URL https://192.168.0.104:8000/. I also don't see it running on port 8000 when i run netstat -tlnp command. I have tried restarting the service and its does it fine. 

Here is the install output


root@arpannas2:~# wget -O- https://raw.github.com/Eugeny/ajenti/master/scripts/i nstall-debian.sh | sh
--2014-10-20 13:41:35-- https://raw.github.com/Eugeny/ajenti/master/scripts/ins tall-debian.sh
Resolving raw.github.com (raw.github.com)... 199.27.79.133
Connecting to raw.github.com (raw.github.com)|199.27.79.133|:443... connected.
HTTP request sent, awaiting response... 301 Moved Permanently
Location: https://raw.githubusercontent.com/Eugeny/ajenti/master/scripts/install -debian.sh [following]
--2014-10-20 13:41:38-- https://raw.githubusercontent.com/Eugeny/ajenti/master/ scripts/install-debian.sh
Resolving raw.githubusercontent.com (raw.githubusercontent.com)... 199.27.79.133
Connecting to raw.githubusercontent.com (raw.githubusercontent.com)|199.27.79.13 3|:443... connected.
HTTP request sent, awaiting response... 200 OK
Length: 472 [text/plain]
Saving to: ‘STDOUT’


100%[======================================>] 472 --.-K/s in 0s


2014-10-20 13:41:39 (1.89 MB/s) - written to stdout [472/472]


:: Installing repo key
--2014-10-20 13:41:40-- http://repo.ajenti.org/debian/key
Resolving repo.ajenti.org (repo.ajenti.org)... 198.232.124.224
Connecting to repo.ajenti.org (repo.ajenti.org)|198.232.124.224|:80... connected .
HTTP request sent, awaiting response... 200 OK
Length: 1716 (1.7K) [application/octet-stream]
Saving to: ‘STDOUT’


100%[======================================>] 1,716 --.-K/s in 0s


2014-10-20 13:41:40 (36.0 MB/s) - written to stdout [1716/1716]


OK
:: Adding repo entry
:: Updating lists
Hit http://mirrors.kernel.org wheezy Release.gpg
Hit http://apt.readynas.com 6.1.9 Release.gpg
Hit http://mirrors.kernel.org wheezy Release
Get:1 http://apt.readynas.com 6.1.9 Release [19.4 kB]
Get:2 http://security.debian.org wheezy/updates Release.gpg [836 B]
Hit http://repo.ajenti.org main Release.gpg
Get:3 http://repo.ajenti.org main Release.gpg [490 B]
Hit http://repo.ajenti.org main Release
Get:4 http://repo.ajenti.org main Release [11.1 kB]
Get:5 http://security.debian.org wheezy/updates Release [102 kB]
Hit http://mirrors.kernel.org wheezy/main armel Packages
Hit http://repo.ajenti.org main/main armel Packages
Get:6 http://apt.readynas.com 6.1.9/updates armel Packages [16.0 kB]
Get:7 http://repo.ajenti.org main/main armel Packages [6,485 B]
Hit http://apt.readynas.com 6.1.9/apps armel Packages
Hit http://apt.readynas.com 6.1.9/main armel Packages
Get:8 http://repo.ajenti.org main/debian armel Packages [1,881 B]
Get:9 http://security.debian.org wheezy/updates/main armel Packages [221 kB]
Fetched 379 kB in 3s (116 kB/s)
Duplicate sources.list entry http://repo.ajenti.org/ng/debian/ main/main armel P ackages (/var/lib/apt/lists/repo.ajenti.org_ng_debian_dists_main_main_binary-arm el_Packages)
You may want to run apt-get update to correct these problems
Reading package lists... Done
W: Duplicate sources.list entry http://repo.ajenti.org/ng/debian/ main/main arme l Packages (/var/lib/apt/lists/repo.ajenti.org_ng_debian_dists_main_main_binary- armel_Packages)
W: You may want to run apt-get update to correct these problems
:: Installing package
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following NEW packages will be installed:
ajenti
0 upgraded, 1 newly installed, 0 to remove and 47 not upgraded.
Need to get 0 B/1,058 kB of archives.
After this operation, 4,438 kB of additional disk space will be used.
debconf: delaying package configuration, since apt-utils is not installed
Selecting previously unselected package ajenti.
(Reading database ... 21830 files and directories currently installed.)
Unpacking ajenti (from .../ajenti_1.2.22.13_all.deb) ...
Setting up ajenti (1.2.22.13) ...
insserv: warning: script 'vpnclient' missing LSB tags and overrides
:: SSL is already configured
------------------------------------------------
Now start Ajenti with 'service ajenti restart'
Ajenti will listen on HTTPS port 8000 by default


Default username : root
Default password : admin
------------------------------------------------
Processing triggers for python-support ...
:: Done! Open https://<address>:8000 in browser
root@arpannas2:~# service ajenti status
ajenti.service - LSB: Ajenti
Loaded: loaded (/etc/init.d/ajenti)
Active: active (exited) since Mon, 20 Oct 2014 13:43:03 -0700; 30s ago
Process: 17038 ExecStop=/etc/init.d/ajenti stop (code=exited, status=0/ SUCCESS)
Process: 14127 ExecStart=/etc/init.d/ajenti start (code=exited, status= 0/SUCCESS)
CGroup: name=systemd:/system/ajenti.service


Oct 20 13:42:59 arpannas2 ajenti[14127]: Starting Ajenti:
Oct 20 13:43:03 arpannas2 ajenti[14127]: 2014-10-20 13:43:03,199 INFO aj...n
Oct 20 13:43:03 arpannas2 ajenti[14127]: started.
root@arpannas2:~# service ajenti restart
[ ok ] Restarting ajenti (via systemctl): ajenti.service.



Can you please help me with this - what am i doing wrong and how do u fix it?

Thanks,
Arpan
GOOD, I'M SATISFIED
Satisfaction mark by Arpan Jain 5 years ago
Under review
Please check the log in /var/log/ajenti. Also: http://support.ajenti.org/topic/507352-troubleshooting/
thanks Eugene! Here is the output:

root@arpannas2:/var/log/ajenti# cat ajenti.log
2014-10-20 13:43:49,853 INFO registry.register_crypt_handler(): registered crypt handler 'sha512_crypt': <class 'passlib.handlers.sha2_crypt.sha512_crypt'>
2014-10-20 13:43:50,867 INFO core.run(): Ajenti 1.2.22.13 running on platform: debian
2014-10-20 13:43:51,185 INFO sm_upstart.verify(): Disabling Upstart service manager: org.freedesktop.DBus.Error.ServiceUnknown: The name com.ubuntu.Upstart was not provided by any .service files
2014-10-20 13:43:52,715 WARNING __init__.load(): *** [elements] Plugin error: format error
2014-10-20 13:43:58,794 ERROR core.handle_crash(): Fatal crash occured
Traceback (most recent call last):
File "/usr/bin/ajenti-panel", line 126, in <module>
core.run()
File "/usr/lib/pymodules/python2.7/ajenti/core.py", line 89, in run
Inflater.get().precache()
File "/usr/lib/pymodules/python2.7/ajenti/ui/inflater.py", line 39, in precache
self.inflate(temp_ui, layout)
File "/usr/lib/pymodules/python2.7/ajenti/ui/inflater.py", line 74, in inflate
self.cache[layout] = self.inflate_rec(ui, xml)
File "/usr/lib/pymodules/python2.7/ajenti/ui/inflater.py", line 110, in inflate_rec
children = filter(None, list(self.inflate_rec(ui, child) for child in node))
File "/usr/lib/pymodules/python2.7/ajenti/ui/inflater.py", line 110, in <genexpr>
children = filter(None, list(self.inflate_rec(ui, child) for child in node))
File "/usr/lib/pymodules/python2.7/ajenti/ui/inflater.py", line 111, in inflate_rec
element = self.create_element(ui, tag, children=children, **props)
File "/usr/lib/pymodules/python2.7/ajenti/ui/inflater.py", line 46, in create_element
inst = cls.new(ui, context=(ui or self).context, *args, **kwargs)
File "/usr/lib/pymodules/python2.7/ajenti/api/__init__.py", line 91, in new
return context.instantiate(cls, *args, **kwargs)
File "/usr/lib/pymodules/python2.7/ajenti/plugins/__init__.py", line 202, in instantiate
init(instance)
File "/usr/lib/pymodules/python2.7/ajenti/plugins/services/main.py", line 62, in init
self.reload()
File "/usr/lib/pymodules/python2.7/ajenti/plugins/services/main.py", line 68, in reload
self.service = ServiceMultiplexor.get().get_one(self.name)
File "/usr/lib/pymodules/python2.7/ajenti/plugins/services/api.py", line 29, in get_one
s = mgr.get_one(name)
File "/usr/lib/pymodules/python2.7/ajenti/plugins/services/api.py", line 45, in get_one
for s in self.get_all():
File "/usr/lib/pymodules/python2.7/ajenti/util.py", line 75, in wrapper
val = fx(*args, **kwargs)
File "/usr/lib/pymodules/python2.7/ajenti/plugins/services/sm_systemd.py", line 26, in get_all
unit_files = self.interface.ListUnitFiles()
File "/usr/lib/python2.7/dist-packages/dbus/proxies.py", line 70, in __call__
return self._proxy_method(*args, **keywords)
File "/usr/lib/python2.7/dist-packages/dbus/proxies.py", line 145, in __call__
**keywords)
File "/usr/lib/python2.7/dist-packages/dbus/connection.py", line 651, in call_blocking
message, timeout)
DBusException: org.freedesktop.DBus.Error.FileNotFound: No such file or directory
2014-10-20 13:44:04,989 ERROR core.handle_crash(): Crash report written to /root/ajenti-crash.txt
2014-10-20 13:44:04,990 ERROR core.handle_crash(): Please submit it to https://github.com/Eugeny/ajenti/issues/new
2014-10-20 13:44:04,990 ERROR : Please submit it to https://github.com/Eugeny/ajenti/issues/new

I have released a small update. Please let me know if it helps.
great - it works :) Thanks Eugene. Now I need to figure out how to setup OpenVPN using this so that all communication from my NAS is via VPN and not directly.