0
Answered

Installing ajenti-v-mail

IvMatt 5 years ago • updated by Ali Karimi 10 months ago 7
I'm unable to install ajenti-v-mail on Centos 6.5, here's the error being output, does anyone know how I can solve this?

Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
epel/metalink                                                                                                             |  26 kB     00:00
 * base: mirror.1steasy.com
 * epel: mirror.bytemark.co.uk
 * extras: mirrors.melbourne.co.uk
 * updates: mirror.1steasy.com
ajenti                                                                                                                    |  951 B     00:00
ajenti/primary                                                                                                            |  24 kB     00:00
ajenti                                                                                                                                     98/98
base                                                                                                                      | 3.7 kB     00:00
base/primary_db                                                                                                           | 3.5 MB     00:00
epel                                                                                                                      | 4.4 kB     00:00
epel/primary_db                                                                                                           | 5.2 MB     00:00
extras                                                                                                                    | 3.4 kB     00:00
extras/primary_db                                                                                                         |  18 kB     00:00
linuxtech                                                                                                                 | 2.6 kB     00:00
linuxtech/primary_db                                                                                                      | 695 kB     00:00
server_mail                                                                                                               | 1.2 kB     00:00
server_mail/primary                                                                                                       |  44 kB     00:00
server_mail                                                                                                                              242/242
updates                                                                                                                   | 3.4 kB     00:00
updates/primary_db                                                                                                        | 3.4 MB     00:00
vz-base                                                                                                                   |  951 B     00:00
vz-base/primary                                                                                                           | 1.3 kB     00:00
vz-base                                                                                                                                      3/3
vz-updates                                                                                                                |  951 B     00:00
vz-updates/primary                                                                                                        | 2.1 kB     00:00
vz-updates                                                                                                                                   8/8
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package ajenti-v-mail.noarch 0:0.1.18-1 will be installed
--> Processing Dependency: courier-authlib-userdb >= 0.64.0 for package: ajenti-v-mail-0.1.18-1.noarch
--> Processing Dependency: courier-imap >= 4.9.3 for package: ajenti-v-mail-0.1.18-1.noarch
--> Processing Dependency: exim for package: ajenti-v-mail-0.1.18-1.noarch
--> Running transaction check
---> Package ajenti-v-mail.noarch 0:0.1.18-1 will be installed
--> Processing Dependency: courier-authlib-userdb >= 0.64.0 for package: ajenti-v-mail-0.1.18-1.noarch
---> Package courier-imap.i686 0:4.15-43.1 will be installed
--> Processing Dependency: courier-authlib >= 0.61 for package: courier-imap-4.15-43.1.i686
--> Processing Dependency: libcourierauth.so for package: courier-imap-4.15-43.1.i686
--> Processing Dependency: fam-server for package: courier-imap-4.15-43.1.i686
--> Processing Dependency: libcourierauthsasl.so for package: courier-imap-4.15-43.1.i686
---> Package exim.i686 0:4.82-60.1 will be installed
--> Running transaction check
---> Package ajenti-v-mail.noarch 0:0.1.18-1 will be installed
--> Processing Dependency: courier-authlib-userdb >= 0.64.0 for package: ajenti-v-mail-0.1.18-1.noarch
---> Package courier-authlib.i386 0:0.63.0-35.2 will be installed
--> Processing Dependency: /usr/bin/expect for package: courier-authlib-0.63.0-35.2.i386
--> Processing Dependency: expect for package: courier-authlib-0.63.0-35.2.i386
---> Package courier-imap.i686 0:4.15-43.1 will be installed
--> Processing Dependency: fam-server for package: courier-imap-4.15-43.1.i686
--> Running transaction check
---> Package ajenti-v-mail.noarch 0:0.1.18-1 will be installed
--> Processing Dependency: courier-authlib-userdb >= 0.64.0 for package: ajenti-v-mail-0.1.18-1.noarch
---> Package courier-imap.i686 0:4.15-43.1 will be installed
--> Processing Dependency: fam-server for package: courier-imap-4.15-43.1.i686
---> Package expect.i686 0:5.44.1.15-5.el6_4 will be installed
--> Processing Dependency: libtcl8.5.so for package: expect-5.44.1.15-5.el6_4.i686
--> Running transaction check
---> Package ajenti-v-mail.noarch 0:0.1.18-1 will be installed
--> Processing Dependency: courier-authlib-userdb >= 0.64.0 for package: ajenti-v-mail-0.1.18-1.noarch
---> Package courier-imap.i686 0:4.15-43.1 will be installed
--> Processing Dependency: fam-server for package: courier-imap-4.15-43.1.i686
---> Package tcl.i686 1:8.5.7-6.el6 will be installed
--> Finished Dependency Resolution
Error: Package: courier-imap-4.15-43.1.i686 (server_mail)
           Requires: fam-server
Error: Package: ajenti-v-mail-0.1.18-1.noarch (ajenti)
           Requires: courier-authlib-userdb >= 0.64.0
           Available: courier-authlib-userdb-0.63.0-35.2.i386 (server_mail)
               courier-authlib-userdb = 0.63.0-35.2
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

Answer

Answer
Answered
We have the required packages in our repo:

-rw-r--r-- 1 root root 35012 Jul 16 18:40 courier-authlib-userdb-0.64.0-1.el6.i686.rpm
-rw-r--r-- 1 root root 35224 Jul 16 18:40 courier-authlib-userdb-0.64.0-1.el6.x86_64.rpm


I've rebuilt the lists just in case (yum clean all), don't know what else I can do for you.
Answer
Answered
We have the required packages in our repo:

-rw-r--r-- 1 root root 35012 Jul 16 18:40 courier-authlib-userdb-0.64.0-1.el6.i686.rpm
-rw-r--r-- 1 root root 35224 Jul 16 18:40 courier-authlib-userdb-0.64.0-1.el6.x86_64.rpm


I've rebuilt the lists just in case (yum clean all), don't know what else I can do for you.
I am having the same issue with DigitalOcean's CentOS 7 droplet.

-
Error: Package: ajenti-v-mail-0.1.22-1.noarch (ajenti)
Requires: courier-imap >= 4.9.3
Error: Package: ajenti-v-mail-0.1.22-1.noarch (ajenti)
Requires: courier-authlib-userdb >= 0.64.0
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest
-

Are the packages in ajenti-repo-1.0-1.noarch.rpm ?
Unfortunately, there are still no EL7 packages of Courier.
Anyway to bypass this errors so that i can install agenti-v-mail?
Ajenti V mail is built upon Exim and Courier mail daemons.
Tried to built ajenti-v-mail to uses on CentOS 7 and since it's to tight with courier I had to give up, ajenti should be compatible with Dovecot since it's more active and reliable.

Hi

I tried to install ajenti-v-mail on centos7 but get the error in install steps

Error: Package: ajenti-v-mail-0.1.36-1.noarch (ajenti)
Requires: courier-authlib-userdb >= 0.64.0
Error: Package: ajenti-v-mail-0.1.36-1.noarch (ajenti)
Requires: courier-imap >= 4.9.3

please help me