0
Wird überprüft

I know you don't do 3rd parties but... owncloud

Temple “Cole” Pate vor 6 Jahren aktualisiert vor 6 Jahren 26
I'm trying to setup a owncloud for my school, and even though you don't do 3rd partie help, is there any information you can give me? I try, but inevitably fail. Then again i'm doing the wordpress installation process as well so. 
Wird überprüft
Hi, please give information on the problem ("Read this first" on the support frontpage).
I am following your wordpress setup on trying to install owncloud, but it doesn't work. Is there a step i am missing?
Not to offend you, but you're missing the step where you explain what exact problem you are encountering.
Sorry let me try this. I have done everything in the wordpress demo you made. The website says maintenence and it is not in maintenance mode. The Mysql database has been made, the files are in owncloud located in /srv/owncloud, but i have a nginx config error.
Check the status of self-tests, which is visible on main Websites page.
Yea, thats what i was referring to the nginx config error stating : 

PHP-FPM service
NGINX config test
nginx: [warn] server name "192.168.122.170/owncloud" has suspicious symbols in /etc/nginx/conf.d/owncloud.conf:8 nginx: [emerg] location "/" is outside location "[^/]\.php(/|$)" in /etc/nginx/conf.d/owncloud.conf:23 nginx: configuration file /etc/nginx/nginx.conf test failed
NGINX service
You have a bad domain name (see Domains section) and also something is wrong with your Content entries (having your /etc/nginx/conf.d/owncloud.conf would help).
the website is a virtual test, what would i name it? I moved the apache conf into nginx.
Apparently your domain contains "/" and domains don't do that.
sorry first time diving into webhosting, i normally just set the server up for someone else to do it. I was under the impression nginx would work like apache, where i would type in 192.168.122.170/owncloud. So what would i use for a similar functionality? Also it is still giving me that error for the nignx config. 
You don't need the domain name to access website using IP. Just remove the "domain". Also please post your .conf file
Removed Domain. Which i will readd with the domain i will be using vs the ip address at launch?
and the conf : 
#AUTOMATICALLY GENERATED - DO NO EDIT!
server {
listen *:80;
server_name 192.168.122.170/owncloud;
access_log /var/log/nginx/owncloud.access.log;
error_log /var/log/nginx/owncloud.error.log;
root /srv/owncloud;
index index.html index.htm index.php;
location ~ [^/]\.php(/|$) {
# This order might seem weird - this is attempted to match last if rules below fail.
location / {
try_files $uri $uri/ /index.php?$args;
}
# Add trailing slash to */wp-admin requests.
rewrite /wp-admin$ $scheme://$host$uri/ permanent;
# Directives to send expires headers and turn off 404 error logging.
location ~* ^.+\.(ogg|ogv|svg|svgz|eot|otf|woff|mp4|ttf|rss|atom|jpg|jpeg|gif|png|ico|zip|tgz|gz|rar|bz2|doc|xls|exe|ppt|tar|mid|midi|wav|bmp|rtf)$ {
access_log off; log_not_found off; expires max;
}
location = /favicon.ico {
log_not_found off;
access_log off;
}
location = /robots.txt {
allow all;
log_not_found off;
access_log off;
}
fastcgi_index index.php;
include fcgi.conf;
fastcgi_pass unix:/var/run/php-fcgi-owncloud-php-fcgi-0.sock;
fastcgi_param SCRIPT_FILENAME $document_root$fastcgi_script_name;
}
}
You have pasted custom location into another location. Remove that. You don't need additional "custom configuration", which is specific to Wordpress
everything is checked, but it still gives a 503 error
Click "Apply" and post generated .conf. You can check for errors in self-tests again too.
#AUTOMATICALLY GENERATED - DO NO EDIT!
server {
listen *:80;
access_log /var/log/nginx/owncloud.access.log;
error_log /var/log/nginx/owncloud.error.log;
root /srv/owncloud;
index index.html index.htm index.php;


No errors on self tests, i am attempting to connect to 192.168.122.170/owncloud correct?
The config looks cut. If self-tests are ok, and maintenance mode is unchecked, you shouldn't receive 503 anymore.
okay, well im going to start from scratch because something isn't working. 
Did a complete reinstall, and everything is setup. new ip is 192.168.122.144, and so i direct myself to 192.168.122.144, and i get a 404 not found. I did remove apache as well. 
Probably your content path isn't pointing to an existing directory. You can read errors in /var/log/nginx/<website>.error.log
All self tests are checked
I have owncloud and wordpress running. The wordpress doesn't have any errors in it's log. the owncloud however has 
2014/05/24 18:50:43 [error] 7031#0: *1 open() "/srv/owncloud/owncloud" failed (2: No such file or directory), client: 192.168.122.1, server: , request: "GET /owncloud HTTP/1.1", host: "192.168.122.144"

And the Nginx error log has 
2014/05/24 18:50:19 [warn] 7033#0: conflicting server name "" on 0.0.0.0:80, ignored
If you have /owncloud Content entry and /srv/owncloud website path, check that "Append path to URL" checkbox is unchecked in that Content entry.
I have unchecked it, it still gives me a 404 not found. I'm pretty sure i'm missing something basic at this point..
Please post content of /etc/ajenti/vh.json (or send it to e@ajenti.org)
So I take that I haven't heard from you in awhile that you've given up on me? I'm not angry or anything, just need to know if I need to stick with the current apache and webmin configuration.