0
Fixed

Permission denied php-fpm socket

Arthur Wiebe 6 years ago updated by Константин Носов 5 years ago 7
Because of a recent PHP update I started getting error in nginx saying it couldn't connect to the upstream PHP-FPM socket.

See http://stackoverflow.com/questions/23443398/nginx-... and https://bugs.php.net/bug.php?id=67060 for details.

The fix for this is to add the following to each FPM socket config:

listen.owner = www-data
listen.group = www-data


So for example:

[websitename-php-fcgi-0]
user = www-data
group = www-data
listen.owner = www-data
listen.group = www-data
listen = /var/run/php-fcgi-websitename-php-fcgi-0.sock
.....



Would you be able to include that config as part of the Ajenti generated config so that it's compatible with the latest PHP security settings.

Thanks.
This is becoming a major issue. And there is no place in Ajenti V to add config to the FPM configuration directly.
Under review
The latest versions of Ajenti V packages already have this fixed.
Ah yes I see that. Is there a change log that you guys have available somewhere?
Unfortunately while Ajenti V is beta, we only have commit log on https://github.com/Eugeny/ajenti-v/commits
Is there any way to change that part of config in current release? Please help to fin how.
+5
I need to change
listen = /var/run/php-fcgi-websitename-php-fcgi-0.sock
to
listen = 127.0.0.1:9000;


but unfortunately ajenti rewrites my changes when restarts