+8
Under review

Website Section not displaying

Saurav Pandey 5 years ago • updated by Cary Landers 7 months ago 17
Hi,

first of all, loved your work.

Now I installed Ajenti with Ajenti V like 4 months ago and it ran fine. Now I logged in and website section is missing. Also before a separate menu item used to come in left hand side menu in section Software, called NginX. Now its not there. Well, without it still my site runs fine but I need Website section to add more domains and other tasks.

I've tried removing and reintalling ajenti, ajenti v both. Restarted it many many times. No effect. Would you happen to know what might be the issue?
PS: Using Ajenti v1.2.22.10 on CentOS 6

Answer

-1
Answer
Under review
Hi Saurav,

Please check expand Ajenti V entry in the Plugins section of the panel to see if there are any plugin loading errors.
-1
Answer
Under review
Hi Saurav,

Please check expand Ajenti V entry in the Plugins section of the panel to see if there are any plugin loading errors.
I have the same problem but im running a debian server
I have the same problem
i use Raspberry Pi 2

HI, since, i had upgrading ajenti to ajenti core 2.1.4, i have the same issue about web section.

I'had trying to follow this fix in the plugins sectio but there no error until now.

Thanks for you help.


I use Debian 8.2 with Nginx server

Had the same issue with Mail. That the ajenti mail package had been removed from my system. I fixed it with reinstalling "ajenti-v-mail" try to do it the same way, just with "... install ajenti-v-nginx" and restart ajenti.

+2

Had the same issue.
Ubuntu server 15.04 fresh install

I'm bumping this as well, as the issue seems to be that other accounts do not have access to the website section. Only Root is allowed access, and i would like to leave root as disabled.

+1

Well i figured how to install the most plugins to have the Website section in Ajenti.

After installing Ajenti on Ubuntu 14.04 you just need to install those packages:

apt-get install ajenti-v agenti-v-nginx ajenti-v-mysql ajenti-v-php-fpm php5-mysql

Then everything will be allright.

Now i'm figuring how to install the webmail ...

Yes, but still the issue still stands that only the root user has access to it.


The mail app is just as easy to install, but at the same time still only is viewable by root.

Does it have any relation with multiserver support ? because in Wikipedia they said that Ajenti didn't support this feature yet.
See this link: https://en.wikipedia.org/wiki/Comparison_of_web_hosting_control_panels

No, this is a single server, with multiple ajenti users.

Run the command:

sudo apt-get install ajenti-v agenti-v-nginx ajenti-v-mysql ajenti-v-php-fpm php5-mysql

sudo service ajenti restart

https://yourip:8000/


i swear the next person to not read the comments. The issue isn't with installing it, it installs fine, but only root has access to ajenti v's settings.

+6

Hi, in fresh automatic install with root user i have no websites area, 

I have folowed all steps 

Including:

# apt-get install ajenti-v ajenti-v-nginx ajenti-v-mysql ajenti-v-php7.0-fpm php7.0-mysql ajenti-v-mail ajenti-v-ruby-puma ajenti-v-ftp-pureftpd ajenti-v-nodejs )

# service ajenti restart


IN panel i ahve only:

GENERAL

 Dashboard

 Plugins

 Settings

TOOLS

 File Manager

 Notepad

 Terminal

SOFTWARE

 Services
 System V

 systemd

SYSTEM

 Packages
 APT

 PIP


Any idea?? i'm new in ajenti :)

After doing update and upgrade I lost my "websites". 


I had to adjust for php7.2 and run the following commands. 

# apt-get install ajenti-v ajenti-v-nginx ajenti-v-mysql ajenti-v-php7.2-fpm php7.2-mysql ajenti-v-mail ajenti-v-ruby-puma ajenti-v-ftp-pureftpd ajenti-v-nodejs 


# sudo service ajenti restart

Same problem. Fresh installation of Ubuntu server 16.04 and I see only few buttons, same as Eugeniu Tambur.

Please, have you any ideas?

Thanks.