0
Answered

Problem installing ajenti on CentOS 5

Rob Rascally 7 years ago updated by Eugene Pankov (Project coordinator) 7 years ago 5

I'm using CentOS 5.9 right now, and I wanted to try ajenti out.  However, after using the RPM directions in the docs, and doing a 'yum install ajenti', I get:


http://repo.ajenti.org/centos/5/i386/repodata/repomd.xml: [Errno 14] HTTP Error 404: Not Found
Trying other mirror.
Error: Cannot retrieve repository metadata (repomd.xml) for repository: ajenti. Please verify its path and try again


Any ideas?

Ajenti does not support CentOS 5.

Hi Rob!


I have added symlinks that will let you use repo from CentOS 5, but I cannot guarantee anything - we don't support it officially. At the very least, you will need to upgrade your Python to 2.6+, and maybe other packages as well.

Please let me know if you'll get any results, thanks!

Awesome, thanks!  I'll check it out and let you know.


Just curious...you guys should really put the system requirements in the docs somewhere.  This thread was the first I have heard of the no CentOS 5 stuff. :)

Hi Rob, did you have a chance to try Ajenti on CentOS 5 yet? 

Yep!  I got this:


Running rpm_check_debug
ERROR with rpm_check_debug vs depsolve:
rpmlib(FileDigests) is needed by reconfigure-0.1.18-1.noarch
rpmlib(PayloadIsXz) is needed by reconfigure-0.1.18-1.noarch
rpmlib(FileDigests) is needed by ajenti-0.99.22-1.noarch
rpmlib(PayloadIsXz) is needed by ajenti-0.99.22-1.noarch
rpmlib(FileDigests) is needed by python-passlib-1.5.3-1.el6.noarch
rpmlib(PayloadIsXz) is needed by python-passlib-1.5.3-1.el6.noarch
Complete!


I'm no coding guru here (I AM the one installing ajenti on an older version of centOS), but maybe this was because of the default python version being too old (I installed 2.6, but of course it's all python26-* there)

I could be way off, too.