0
Answered

Default Path to Website?

miniNodes.com 6 years ago updated by Murray BCP 5 years ago 5

Am I correct in assuming that the default path for nginx on Ajenti-V is "/usr/share/nginx/www"?  

In that folder I see Ajenti created these two files:

/usr/share/nginx/www/50x.html

/usr/share/nginx/www/index.html


When adding a website in Ajenti-V, I define the domain name, port, and then go to select the path to the site...but...the dialog box that opens starts at the root of the filesystem.  Perhaps it could just default to the path to nginx home (and allow the user to navigate the filesystem from there if they need to)?


That's just a thought, and, thanks for the AWESOME work you are doing!


-David

http://www.mininodes.com

Answer

Answer
Answered

Complete! Bonus: automatic downloader/unpacker for e.g. Wordpress

GOOD, I'M SATISFIED

Awesome!

Satisfaction mark by miniNodes.com 6 years ago

Ah, ok, that makes sense on the 2 files then.


The reason I was asking though, is because I can see how the less-technical users may get confused.  Additionally, if the user does not already have content on the server (lets say they want to upload WordPress or Joomla) they will typically use FTP.  If they haven't chosen a path, they will inadvertently upload the WordPress files and folders to the root of the filesystem.


Additionally, they are permissions issues that need to be considered on a web accessible folder, so that was another reason for my question.


Again, these were just thoughts / opinions I had while testing, and I really appreciate the Ajenti Project!

Answer
Answered

Complete! Bonus: automatic downloader/unpacker for e.g. Wordpress

David/Eugene

I'm a Linux & VPS newbie.  Appreciated your info in your first post here.

Due to no support documentation on how to setup a basic website on AjentiV, I started to see how to do it from your post above.

Still not working though.

From a basic new AjentiV installation, I wanted to add a bunch of web files to launch a simple website.

1.   Websites > Create a name > go to the created name's setup options.

2.   General tab > Website files path /usr/share/nginx/html      and maintenance mode switched off.

3.   Domains tab > add the real domain name without the "www"

4.   Ports tab > leave the Hosts as * and port number "80" as is.

5.   Remaining tabs I dont touch.

Saved and applied all changes as I went.

Checked all configurations under "Websitesa" are running.   Went to the domain name in a new browser page and it didnt work.  Got 503 Service is unavailable due to maintenance (but maintenance mode was off).

Software installed, according to Ajenti is Mysql, Postgre, Bind9, Apache.

Is there anything else I need to do?

David, you did talk about user permissions, but I have touched nothing there.

Apart from Joomla and Wordpress auto installs info provided, there should be a basic instruction about how to do all of this, and then added notes for securing the server as needed.
Hi,

A working website requires at least one "Content" entry (Static files would be ok, to start).
If your changes do not seem to get applied, check if everything is fine by looking at Configuration checks list (at the main Websites page).
There are guides available at http://support.ajenti.org/list/27624-kb/?category=9332
Eugene

Still getting 503 Service Unavailable due to maintenance mode (but is off!!).

I added a line under Content> Static - but is it right?  I simply added  under URL pattern: 

/usr/share/nginx/condellprojex.net/index.html   EXACT

All the HTML files are with the index.html at the location above.

...looked at your guides for other more complex websites, but doesnt mean much to me.  It would still be better to have a basic HTML website example.  Please?