0

IMAP Trouble

53RG0 5 years ago updated 5 years ago 5

IMAP server does not work, but SMTP works fine.
I dont know what to do... help pls

still trouble



***** = MY_DOMAIN


# exim -d -bt adm@*****.net

Exim version 4.72 uid=0 gid=0 pid=6045 D=fbb95cfd
Berkeley DB: Berkeley DB 4.7.25: (September 9, 2013)
Support for: crypteq iconv() IPv6 PAM Perl Expand_dlfunc TCPwrappers OpenSSL Content_Scanning DKIM Old_Demime
Lookups (built-in): lsearch wildlsearch nwildlsearch iplsearch cdb dbm dbmnz dnsdb dsearch ldap ldapdn ldapm nis nis0 nisplus passwd sqlite
Authenticators: cram_md5 cyrus_sasl dovecot plaintext spa
Routers: accept dnslookup ipliteral manualroute queryprogram redirect
Transports: appendfile/maildir/mailstore/mbx autoreply lmtp pipe smtp
Fixed never_users: 0
Size of off_t: 8
OpenSSL compile-time version: OpenSSL 1.0.1e-fips 11 Feb 2013
OpenSSL runtime version: OpenSSL 1.0.1e-fips 11 Feb 2013
changed uid/gid: forcing real = effective
uid=0 gid=0 pid=6045
auxiliary group list: <none>
seeking password data for user "uucp": cache not available
getpwnam() succeeded uid=10 gid=14
configuration file is /etc/exim/exim.conf
log selectors = 00000ffc 00212001
Loading lookup modules from /usr/lib64/exim/4.72-7.el6/lookups
Loaded 0 lookup modules
Total 17 lookups
trusted user
admin user
seeking password data for user "mail": cache not available
getpwnam() succeeded uid=8 gid=12
seeking password data for user "mail": using cached result
getpwnam() succeeded uid=8 gid=12
user name "root" extracted from gecos field "root"
originator: uid=0 gid=0 login=root name=root
sender address = root@localhost
Address testing: uid=0 gid=93 euid=0 egid=93
>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>
Testing adm@*****.net
>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>
Considering adm@*****.net
>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>
routing adm@*****.net
--------> vforward router <--------
local_part=adm domain=*****.net
checking domains
*****.net in "*****.net : autoprofit.te.ua : localhost"? yes (matched "*****.net")
*****.net in "+local_domains"? yes (matched "+local_domains")
R: vforward for adm@*****.net
calling vforward router
rda_interpret (file): /etc/exim.forward/$local_part@$domain
expanded: /etc/exim.forward/adm@*****.net
/etc/exim.forward/adm@*****.net does not exist
checking parent directory
stat(/etc/exim.forward/.)=0
/etc/exim.forward/adm@*****.net does not exist
vforward router declined for adm@*****.net
--------> vdomain router <--------
local_part=adm domain=*****.net
checking domains
search_open: dsearch "/etc/exim.domains"
search_find: file="/etc/exim.domains"
key="*****.net" partial=-1 affix=NULL starflags=0
LRU list:
4/etc/exim.domains
End
internal_search_find: file="/etc/exim.domains"
type=dsearch key="*****.net"
file lookup required for *****.net
in /etc/exim.domains
lookup yielded: *****.net
*****.net in "dsearch;/etc/exim.domains"? yes (matched "dsearch;/etc/exim.domains")
checking local_parts
search_open: lsearch "/etc/exim.domains/*****.net"
search_find: file="/etc/exim.domains/*****.net"
key="adm" partial=-1 affix=NULL starflags=0
LRU list:
9/etc/exim.domains/*****.net
4/etc/exim.domains
End
internal_search_find: file="/etc/exim.domains/*****.net"
type=lsearch key="adm"
file lookup required for adm
in /etc/exim.domains/*****.net
lookup yielded:
adm in "lsearch;/etc/exim.domains/*****.net"? yes (matched "lsearch;/etc/exim.domains/*****.net")
R: vdomain for adm@*****.net
calling vdomain router
vdomain router called for adm@*****.net
domain = *****.net
set transport vmail
queued for vmail transport: local_part = adm
domain = *****.net
errors_to=NULL
domain_data=*****.net localpart_data=
routed by vdomain router
envelope to: adm@*****.net
transport: vmail
adm@*****.net
router = vdomain, transport = vmail
search_tidyup called
>>>>>>>>>>>>>>>> Exim pid=6045 terminating with rc=0 >>>>>>>>>>>>>>>>


telnet localhost 143

Trying ::1...
Connected to localhost.
Escape character is '^]'.
* OK [CAPABILITY IMAP4rev1 UIDPLUS CHILDREN NAMESPACE THREAD=ORDEREDSUBJECT THREAD=REFERENCES SORT QUOTA IDLE ACL ACL2=UNION] Courier-IMAP ready. Copyright 1998-2011 Double Precision, Inc. See COPYING for distribution information.

I found all emails in folder var/vmails/domain/adm/new/

[root@localhost ~]# telnet localhost 143

Trying ::1...
Connected to localhost.
Escape character is '^]'.
* OK [CAPABILITY IMAP4rev1 UIDPLUS CHILDREN NAMESPACE THREAD=ORDEREDSUBJECT THREAD=REFERENCES SORT QUOTA IDLE ACL ACL2=UNION] Courier-IMAP ready. Copyright 1998-2011 Double Precision, Inc. See COPYING for distribution information.
0 login adm@******.net *pass*
0 OK LOGIN Ok.
0 select inbox
* FLAGS (\Draft \Answered \Flagged \Deleted \Seen \Recent)
* OK [PERMANENTFLAGS (\* \Draft \Answered \Flagged \Deleted \Seen)] Limited
* 25 EXISTS
* 25 RECENT
* OK [UIDVALIDITY 1455318059] Ok
* OK [MYRIGHTS "acdilrsw"] ACL
0 OK [READ-WRITE] Ok
0 list
0 NO Error in IMAP command received by server.
0 list "" "*"
* LIST (\Marked \HasNoChildren) "." "INBOX"
0 OK LIST completed


Feb 12 18:00:27 localhost imapd: Connection, ip=[::1]

Feb 12 18:00:35 localhost imapd: LOGIN, user=adm@*******.net, ip=[::1], port=[45834], protocol=IMAP
Feb 12 18:32:21 localhost imapd: adm@******: TOO MANY CONSECUTIVE PROTOCOL VIOLATIONS