0
Wird überprüft

BSD Install Script Gone?

Joey Famiglietti vor 6 Jahren aktualisiert von denus vor 5 Jahren 9
Hello everyone!

I'm working on a project for both personal edification and as an exercise for a friend. It's a bit of a weird circumstance, but that's okay. I'm attempting to install Ajenti in a FreeNAS Plugin Jail running a FAMP stack. I've been following this tutorial (http://www.iceflatline.com/2011/11/how-to-install-apache-mysql-php-and-phpmyadmin-on-freebsd/) up until the Wordpress part, because, well, I'm not installing Wordpress...but Ajenti will be of assistance for the next steps. All of the steps in the tutorial worked fine; Apache is happily serving up the "it works" page, MySQL is happily eating up RAM with its complete dearth of data, phpMyAdmin is sitting around doing its thing, etc. There are no visible problems there.

I copy/pasted the prerequisites from the Ajenti installer, which all worked fine. When I went to download the install script, I get the following results:

---------------------------------------------------

root@fusioninvoice:/etc/rc.d # wget https://raw.github.com/Eugeny/ajenti/master/packaging/files/ajenti-bsd -O /etc/rc.d/ajenti
--2014-10-09 18:30:06-- https://raw.github.com/Eugeny/ajenti/master/packaging/files/ajenti-bsd
Resolving raw.github.com (raw.github.com)... 199.27.76.133
Connecting to raw.github.com (raw.github.com)|199.27.76.133|:443... connected.
ERROR: cannot verify raw.github.com's certificate, issued by '/C=US/O=DigiCert Inc/OU=www.digicert.com/CN=DigiCert High Assurance CA-3':
Unable to locally verify the issuer's authority.
To connect to raw.github.com insecurely, use `--no-check-certificate'.
--------------------------------------

So I did what it said, and got a bit further:

----------------------------------------
root@fusioninvoice:/etc/rc.d # wget https://raw.github.com/Eugeny/ajenti/master/packaging/files/ajenti-bsd -O /etc/rc.d/ajenti --no-check-certificate
--2014-10-09 18:30:14-- https://raw.github.com/Eugeny/ajenti/master/packaging/files/ajenti-bsd
Resolving raw.github.com (raw.github.com)... 199.27.76.133
Connecting to raw.github.com (raw.github.com)|199.27.76.133|:443... connected.
WARNING: cannot verify raw.github.com's certificate, issued by '/C=US/O=DigiCert Inc/OU=www.digicert.com/CN=DigiCert High Assurance CA-3':
Unable to locally verify the issuer's authority.
HTTP request sent, awaiting response... 301 Moved Permanently
Location: https://raw.githubusercontent.com/Eugeny/ajenti/master/packaging/files/ajenti-bsd [following]
--2014-10-09 18:30:14-- https://raw.githubusercontent.com/Eugeny/ajenti/master/packaging/files/ajenti-bsd
Resolving raw.githubusercontent.com (raw.githubusercontent.com)... 199.27.76.133
Connecting to raw.githubusercontent.com (raw.githubusercontent.com)|199.27.76.133|:443... connected.
WARNING: cannot verify raw.githubusercontent.com's certificate, issued by '/C=US/O=DigiCert Inc/OU=www.digicert.com/CN=DigiCert High Assurance CA-3':
Unable to locally verify the issuer's authority.
HTTP request sent, awaiting response... 200 OK
Length: 312 [text/plain]
Saving to: '/etc/rc.d/ajenti'
100%[==========================================================================>] 312 --.-K/s in 0s
2014-10-09 18:30:14 (15.2 MB/s) - '/etc/rc.d/ajenti' saved [312/312]
root@fusioninvoice:/etc/rc.d #
---------------------------------------

I greatly appreciate any and all assistance available. Conversely, if I can provide any more information to assist in this respect, please let me know.

Best Regards,
Joey

Antwort

Antwort
Wird überprüft
Hi Joey,

Please check that your date & time settings are correct - this is the most often cause of SSL failures.
Antwort
Wird überprüft
Hi Joey,

Please check that your date & time settings are correct - this is the most often cause of SSL failures.
Thanks for getting back to me Eugene!

I took a look, and it seems that my date and time are indeed accurate. I also took a deeper look, and it seems that the file being downloaded did indeed get to its intended target, and there's stuff named 'ajenti' floating around in my /usr/local/bin folder...so it looks like more stuff happened than I thought.
I did the Ubuntu installer without an issue, so I was expecting a similar, super-simple experience like that to get Ajenti installed, but it looks like the BSD variant is a bit more involved. Please forgive me as this is a learning exercise and although I'm *nix literate, I'm not savvy. Thus, it looks like the situation is that either Ajenti isn't installed, or it's installed but not running. Here's some data that may be relevant:

root@fusioninvoice:/usr/local/bin # ls -alFh | grep "ajenti"
-rwxr-xr-x 1 root wheel 1.0k Oct 9 18:07 ajenti-ipc*
-rwxr-xr-x 1 root wheel 3.8k Oct 9 18:07 ajenti-panel*
-rwxr-xr-x 1 root wheel 1.5k Oct 9 18:07 ajenti-ssl-gen*

root@fusioninvoice:/usr/local/bin # ps -aux | grep "ajenti"
root 96757 0.0 0.0 16312 1676 0 S+J 10:51AM 0:00.00 grep ajenti

Thanks again!

Joey
So... have you tried running ajenti-panel? It should start the panel in foreground mode (for testing). If that works fine, go ahead and start it as a service using the rc.d script you have downloaded.
root@fusioninvoice:/usr/local/bin # ajenti-panel
ajenti-panel: Command not found.


root@fusioninvoice:/etc/rc.d # ./ajenti start
eval: /usr/local/bin/ajenti-panel: not found

That's what I get when I attempt to run the executable directly, or run the script. I feel like I missed something, somewhere.
Looks like /usr/local/bin isn't on your $PATH.
If you're currently in /usr/local/bin, you need to execute: ./ajenti-panel
root@fusioninvoice:/usr/local/bin # ./ajenti-panel
./ajenti-panel: Command not found.
But your previous commands' output show that /usr/local/bin/ajenti-panel exists and is executable. How can this be?
I'll make a new jail and start completely from scratch, keeping a copious log of everything that goes into Xshell. Maybe I missed something and didn't realize it. I'll let you know if I have any better success. If there's any other thoughts as to why this is happening, I'll leave this jail alone until I've got something working.

I really appreciate your help, Eugene!
Try
ln -s /usr/local/bin/python2 /usr/bin/python