0

Mailboxes can't be accessed by any imap clientclient, Ajenti-V

JL Griffin 6 years ago updated by Pierre Knudsen 5 years ago 7
I have a ton of email accounts on my server. The number one issue that myself and my customers have had since switching to i mm ajenti is that no one can access their email other than through roundcube. Mobile phone IMAP clients do not access the emails they say that they cannot connect to the server. Desktop email apps including outlook, thunderbird, Opera Mail, Claws mail and several others cannot access any accounts. They say they cannot connect to the server. Mail logs show that the applications connect then disconnect within the same second. What's going on? I have tried every variation of ports and settings to no avail. The only way people can access emails, is through roundcube. Roundcube is configured to connect to localist, and if I change roundcube configuration so that it is connecting for emails to the outside IP address instead of localhost, the same issue occurs there. What's going on? How can I get this working? Ive been trying for months and I'm at a loss. Help.
Apologies for the typos, i was typing this from my phone, and i must say This forum is pretty awful when it comes to using mobile devices. Let me correct the typos.

*Switching to Ajenti-V
*Roundcube is configured to connect to localhost
Hi folks, i have similar problem. account created in ajenti, after try to login:
yuno@mail:/var/www/yui$ telnet localhost imap
Trying ::1...
Connected to mail.***.sk.
Escape character is '^]'.
* OK [CAPABILITY IMAP4rev1 UIDPLUS CHILDREN NAMESPACE THREAD=ORDEREDSUBJECT THREAD=REFERENCES SORT QUOTA IDLE ACL ACL2=UNION STARTTLS] Courier-IMAP ready. Copyright 1998-2011 Double Precision, Inc. See COPYING for distribution information.
A1 LOGIN skuska@***.sk skuska22
* BYE Temporary problem, please try again later
Connection closed by foreign host.

in logs:
yuno@mail:/var/www/yui$ tail /var/log/mail.err
May 28 12:44:13 mail imapd: authentication error: Permission denied

password is correct, printing list of vmail dir:
yuno@mail:/var/www/yui$ sudo ls -lha /var/vmail/
celkom 24K
drw-rw-r-- 6 vmail vmail 4,0K apr 2 12:50 .
drwxr-xr-x 15 root root 4,0K apr 1 09:06 ..
drwxr-xr-x 3 vmail vmail 4,0K apr 13 09:30 backup
drwx------ 2 vmail vmail 4,0K apr 1 09:24 sieve
drwx------ 3 vmail vmail 4,0K apr 1 09:06 vmail1
drwxrwxrwx 3 vmail vmail 4,0K apr 2 12:50 wak.sk

yuno@mail:/var/www/yui$ sudo ls -lha /var/vmail/vmail1
celkom 12K
drwx------ 3 vmail vmail 4,0K apr 1 09:06 .
drw-rw-r-- 6 vmail vmail 4,0K apr 2 12:50 ..
drwx------ 3 vmail vmail 4,0K apr 1 09:06 wak.sk
yuno@mail:/var/www/yui$ sudo ls -lha /var/vmail/wak.sk
celkom 12K
drwxrwxrwx 3 vmail vmail 4,0K apr 2 12:50 .
drw-rw-r-- 6 vmail vmail 4,0K apr 2 12:50 ..
drwxrwsrwx 5 vmail vmail 4,0K apr 2 12:50 skuska

any idea, how to solve it? many thanks!

and alas another year goes by worth no assistance. Love the panel. Support is awfulawful...

+1

For me it sounds like you are forced to use SSL/TLS. That means u need to use Port 993 instead of 143. and "ssl://Your-IP" in roundcube to get it work with IP. Maybe you need and Valid SSL Certificate like StartSSL too (In the TLS section of your Mail settings)(Ajenti Generator just creates " Self Signed" certificates. Than it should work with other Clients too.

Can you tell me what happens if u use the roundcube installer (In Step two with IP (Only IP without SSL://) and port 143) and in Step 3 the IMap login tester. If it says something with "Wrong greeting MSG" or "STARTSSL needed" i can help you.


Sry for bad english :)

Localhost and roundcube has no issue. its every other imap client. they connect then disconnect which usually returns an "authentication failed" error but authentication hasnt even started

But i'm sure with localhost you only mean "localhost" or "127.0.0.1" and not your local IP. Like i said, try it with StartSSL.com for a Certificate. That fixed the problem for me.


##Does it work, if you use your IP instead of localhost in your Roundcube installation?