0

Domain not pointing to correct path

Xeronik 5 år siden opdateret af Pierre Knudsen 5 år siden 1

I am currently trying to set up the first Homepage on my server with ajenti. However, if I navigate my browser to the Domain, I end up seeing the standard index.html of nginx.


I have read the knowledgebase-tutorial on how to create a website but i did the exact same steps on my server. Here is what I did:


1. I created a new website in Ajenti.

2. I set the directory of the website to /srv/domain

3. I added the Domain to the website(in ajenti, "domain.de" for example)

4. I setted the FTP path(which is working)

5. And i unchecked the maintenance mode.


As i created the website, i had some troubles with ajenti v being out of date. I ended up with an error which said 'WebsitePort' object has no attribute 'http2'.


I updated ajenti and got that fixed. Could that have any affects on my not working website config?

Normaly it shouldn't be a problem. If you save the settings, it replace the old "Domain.de.conf" in "/etc/nginx/conf.d/" with the new saved one. Thats why you should never edit the .conf manually, because it gets replaced if u save something in the Website section.


Sry for bad english :)

Kundesupport af UserEcho