0

Installation on a raspberry pi failed

Federico Bellizia 5 lat temu zaktualizowano 5 lat temu 3

root@whatsapp1:~# pip install ajenti --upgrade
/usr/local/lib/python2.7/dist-packages/pip/_vendor/requests/packages/urllib3/util/ssl_.py:90: InsecurePlatformWarning: A true SSLContext object is not available. This prevents urllib3 from configuring SSL appropriately and may cause certain SSL connections to fail. For more information, see https://urllib3.readthedocs.org/en/latest/security.html#insecureplatformwarning.
InsecurePlatformWarning
Requirement already up-to-date: ajenti in /usr/lib/pymodules/python2.7
Requirement already up-to-date: gevent in /usr/local/lib/python2.7/dist-packages (from ajenti)
Requirement already up-to-date: gevent-socketio in /usr/lib/python2.7/dist-packages (from ajenti)
Requirement already up-to-date: gevent-websocket in /usr/local/lib/python2.7/dist-packages (from ajenti)
Requirement already up-to-date: lxml>=2.2.4 in /usr/local/lib/python2.7/dist-packages (from ajenti)
Requirement already up-to-date: passlib in /usr/local/lib/python2.7/dist-packages (from ajenti)
Requirement already up-to-date: psutil>=0.6.0 in /usr/local/lib/python2.7/dist-packages (from ajenti)
Requirement already up-to-date: python-catcher in /usr/lib/pymodules/python2.7 (from ajenti)
Requirement already up-to-date: python-daemon in /usr/local/lib/python2.7/dist-packages (from ajenti)
Requirement already up-to-date: python-exconsole>=0.1.5 in /usr/lib/pymodules/python2.7 (from ajenti)
Requirement already up-to-date: python-ldap in /usr/local/lib/python2.7/dist-packages (from ajenti)
Requirement already up-to-date: requests>=0.12.0 in /usr/local/lib/python2.7/dist-packages (from ajenti)
Requirement already up-to-date: reconfigure>=0.1.43 in /usr/lib/pymodules/python2.7 (from ajenti)
Requirement already up-to-date: pyOpenSSL in /usr/local/lib/python2.7/dist-packages (from ajenti)
Requirement already up-to-date: Pillow in /usr/local/lib/python2.7/dist-packages (from ajenti)
Requirement already up-to-date: greenlet>=0.4.9 in /usr/local/lib/python2.7/dist-packages (from gevent->ajenti)
Requirement already up-to-date: Mako in /usr/local/lib/python2.7/dist-packages (from python-catcher->ajenti)
Requirement already up-to-date: setuptools in /usr/local/lib/python2.7/dist-packages (from python-daemon->ajenti)
Requirement already up-to-date: docutils in /usr/local/lib/python2.7/dist-packages (from python-daemon->ajenti)
Requirement already up-to-date: lockfile>=0.10 in /usr/local/lib/python2.7/dist-packages (from python-daemon->ajenti)
Requirement already up-to-date: chardet in /usr/local/lib/python2.7/dist-packages (from reconfigure>=0.1.43->ajenti)
Requirement already up-to-date: cryptography>=0.7 in /usr/local/lib/python2.7/dist-packages (from pyOpenSSL->ajenti)
Requirement already up-to-date: six>=1.5.2 in /usr/local/lib/python2.7/dist-packages (from pyOpenSSL->ajenti)
Requirement already up-to-date: MarkupSafe>=0.9.2 in /usr/local/lib/python2.7/dist-packages (from Mako->python-catcher->ajenti)
Requirement already up-to-date: pbr!=0.7,<1.0,>=0.6 in /usr/local/lib/python2.7/dist-packages (from lockfile>=0.10->python-daemon->ajenti)
Requirement already up-to-date: idna>=2.0 in /usr/local/lib/python2.7/dist-packages (from cryptography>=0.7->pyOpenSSL->ajenti)
Requirement already up-to-date: pyasn1>=0.1.8 in /usr/local/lib/python2.7/dist-packages (from cryptography>=0.7->pyOpenSSL->ajenti)
Requirement already up-to-date: enum34 in /usr/local/lib/python2.7/dist-packages (from cryptography>=0.7->pyOpenSSL->ajenti)
Requirement already up-to-date: ipaddress in /usr/local/lib/python2.7/dist-packages (from cryptography>=0.7->pyOpenSSL->ajenti)
Requirement already up-to-date: cffi>=1.1.0 in /usr/local/lib/python2.7/dist-packages (from cryptography>=0.7->pyOpenSSL->ajenti)
Requirement already up-to-date: pip in /usr/local/lib/python2.7/dist-packages (from pbr!=0.7,<1.0,>=0.6->lockfile>=0.10->python-daemon->ajenti)
Requirement already up-to-date: pycparser in /usr/local/lib/python2.7/dist-packages (from cffi>=1.1.0->cryptography>=0.7->pyOpenSSL->ajenti)
/usr/local/lib/python2.7/dist-packages/pip/_vendor/requests/packages/urllib3/util/ssl_.py:90: InsecurePlatformWarning: A true SSLContext object is not available. This prevents urllib3 from configuring SSL appropriately and may cause certain SSL connections to fail. For more information, see https://urllib3.readthedocs.org/en/latest/security.html#insecureplatformwarning.
InsecurePlatformWarning
root@whatsapp1:~# service ajenti restart
Stopping Ajenti:
[FAIL] not running ... failed!
Starting Ajenti:
Traceback (most recent call last):
File "/usr/bin/ajenti-panel", line 11, in <module>
import ajenti.log
File "/usr/lib/pymodules/python2.7/ajenti/log.py", line 7, in <module>
from ajenti.api import extract_context
File "/usr/lib/pymodules/python2.7/ajenti/api/__init__.py", line 6, in <module>
from ajenti.plugins import manager, PluginContext
File "/usr/lib/pymodules/python2.7/ajenti/plugins/__init__.py", line 9, in <module>
from ajenti.util import *
File "/usr/lib/pymodules/python2.7/ajenti/util.py", line 2, in <module>
import catcher
File "/usr/lib/pymodules/python2.7/catcher/__init__.py", line 2, in <module>
from . import uploaders
File "/usr/lib/pymodules/python2.7/catcher/uploaders/__init__.py", line 1, in <module>
from .ajentiorg import AjentiOrgUploader
ImportError: No module named ajentiorg
[FAIL] failed ... failed!

python_catcher-0.1.7.egg-info/SOURCES.txt:catcher/uploaders/ajentiorg.py

I tried git clone, build and install... same problem:

Using /usr/local/lib/python2.7/dist-packages
Searching for pip==7.1.2
Best match: pip 7.1.2
Adding pip 7.1.2 to easy-install.pth file
Installing pip script to /usr/local/bin
Installing pip2.7 script to /usr/local/bin
Installing pip2 script to /usr/local/bin



Using /usr/local/lib/python2.7/dist-packages
Finished processing dependencies for ajenti==1.2.23.0
root@whatsapp1:~/ajenti# service ajenti restart
Stopping Ajenti:
[FAIL] not running ... failed!
Starting Ajenti:
Traceback (most recent call last):
File "/usr/bin/ajenti-panel", line 11, in <module>
import ajenti.log
File "/usr/local/lib/python2.7/dist-packages/ajenti-1.2.23.0-py2.7.egg/ajenti/log.py", line 7, in <module>
from ajenti.api import extract_context
File "/usr/local/lib/python2.7/dist-packages/ajenti-1.2.23.0-py2.7.egg/ajenti/api/__init__.py", line 6, in <module>
from ajenti.plugins import manager, PluginContext
File "/usr/local/lib/python2.7/dist-packages/ajenti-1.2.23.0-py2.7.egg/ajenti/plugins/__init__.py", line 9, in <module>
from ajenti.util import *
File "/usr/local/lib/python2.7/dist-packages/ajenti-1.2.23.0-py2.7.egg/ajenti/util.py", line 2, in <module>
import catcher
File "/usr/lib/pymodules/python2.7/catcher/__init__.py", line 2, in <module>
from . import uploaders
File "/usr/lib/pymodules/python2.7/catcher/uploaders/__init__.py", line 1, in <module>
from .ajentiorg import AjentiOrgUploader
ImportError: No module named ajentiorg
[FAIL] failed ... failed!


Problem resolved... installed webmin + bootstrap theme :)