+6

MongoDB plugin needs pymongo 2.8

David Mehren 4 aastat tagasi uuendaja mareksierocinski 3 aastat tagasi 1

I set up Ajenti with Ubuntu 15.10 and installed the MongoDB Plugin.
After I installed pymongo with 'pip install pymongo' Ajenti refused to connect with the error "TypeError: 'Database' object is not callable. If you meant to call the 'disconnect' method on a 'MongoClient' object it is failing because no such method exists."

After some trying I discovered that the old version 2.8 of pymongo works well.
You should either document this or support the current pymongo version.

I have installed version 2.8 and it's not working :(