0
Answered

How do I setup a static webpage?

Daniel Tsionit 5 years ago updated by Eugene Pankov (Project coordinator) 5 years ago 5

Answer

+1
Answer
Answered
1. Put your website files (including index.html) under the selected website path.
2. Add a single Static files content entry in the website settings.
3. Save
GOOD, I'M SATISFIED
Satisfaction mark by Daniel Tsionit 5 years ago
+1
Answer
Answered
1. Put your website files (including index.html) under the selected website path.
2. Add a single Static files content entry in the website settings.
3. Save
Done this already. I am getting error "403" form nginx...
+1
It's important to provide this information straightaway, so that I could figure out your problem as fast as possible. Do your website directory permission allow read access? Try click "Fix permissions" in the website settings. Also, check /var/log/nginx/website.error.log file.
Hi, I managed to fix it thanks!

I checked my logs like you told me:


HTTP/1.1", host: "test.ajenti.local", referrer: "http://test.ajenti.local/"
2014/09/13 22:30:52 [error] 6692#0: *7 open() "/srv/test.ajenti.local/www/css/main.css" failed (2: No such file or directory), client: 10.0.0.3, server: test.ajenti.local, request: "GET /css/main.css HTTP/1.1", host: "test.ajenti.local", referrer: "http://test.ajenti.local/"
2014/09/13 22:30:52 [error] 6692#0: *10 open() "/srv/test.ajenti.local/www/js/main.js" failed (2: No such file or directory), client: 10.0.0.3, server: test.ajenti.local, request: "GET /js/main.js HTTP/1.1", host: "test.ajenti.local", referrer: "http://test.ajenti.local/"
2014/09/13 22:31:01 [error] 6692#0: *10 open() "/srv/test.ajenti.local/www/js/main.js" failed (2: No such file or directory), client: 10.0.0.3, server: test.ajenti.local, request: "GET /js/main.js HTTP/1.1", host: "test.ajenti.local", referrer: "http://test.ajenti.local/"
2014/09/13 22:31:01 [error] 6692#0: *9 open() "/srv/test.ajenti.local/www/css/normalize.css" failed (2: No such file or directory), client: 10.0.0.3, server: test.ajenti.local, request: "GET /css/normalize.css HTTP/1.1", host: "test.ajenti.local", referrer: "http://test.ajenti.local/"
2014/09/13 22:31:01 [error] 6692#0: *8 open() "/srv/test.ajenti.local/www/js/plugins.js" failed (2: No such file or directory), client: 10.0.0.3, server: test.ajenti.local, request: "GET /js/plugins.js HTTP/1.1", host: "test.ajenti.local", referrer: "http://test.ajenti.local/"
2014/09/13 22:31:01 [error] 6692#0: *7 open() "/srv/test.ajenti.local/www/js/vendor/modernizr-2.6.2.min.js" failed (2: No such file or directory), client: 10.0.0.3, server: test.ajenti.local, request: "GET /js/vendor/modernizr-2.6.2.min.js HTTP/1.1", host: "test.ajenti.local", referrer: "http://test.ajenti.local/"
2014/09/13 22:31:01 [error] 6692#0: *6 open() "/srv/test.ajenti.local/www/css/main.css" failed (2: No such file or directory), client: 10.0.0.3, server: test.ajenti.local, request: "GET /css/main.css HTTP/1.1", host: "test.ajenti.local", referrer: "http://test.ajenti.local/"


the permissions was fine, it was the SElinux security causing the errors...

for now I disabled it with: setenforce 0
Until I set it up properly.


Glad you have resolved it :)
Hint: you'll need to allow www-data user access to the files.