0

Ubuntu Server: Ajenti Works with HTTP but will not load https://<ip>:8000

John Down 5 years ago updated by Alex Shele100 5 years ago 8
I installed Ajenti and it works fine when I turn off SSL certificates but when they are on and I try to go to https://<ip>:8000 it does not load Ajenti.

Installed on a Ubuntu 14.04. Suggestions?

you said , you turnd of ssl
so when you turn of ssl , you cant acces with https:// ,try http://
with ssl on use https://
with ssl of use http://

sorry for my bad english, be happy

Yes, without SSL it works but with it will not.
Make sure you have the correct Path to certificate. If so, try to generate a new certificate (from Configure).
Same problem... Fresh install Xubuntu 15.04
What are the steps you took to install? Did you install using similar steps as this: https://gist.github.com/Seanmcn/62a021a765ad4f8e593b
Basically yes. It is easy to reproduce this error on fresh xubuntu 15.04 amd64 installation. nonSSL works fine.

/usr/bin/ajenti-panel -v
Traceback (most recent call last): File "/usr/lib/python2.7/dist-packages/gevent/greenlet.py", line 327, in run result = self._run(*self.args, **self.kwargs) File "/usr/lib/python2.7/dist-packages/gevent/server.py", line 102, in wrap_socket_and_handle ssl_socket = self.wrap_socket(client_socket, **self.ssl_args) File "/usr/lib/python2.7/dist-packages/gevent/ssl.py", line 382, in wrap_socket ciphers=ciphers) File "/usr/lib/python2.7/dist-packages/gevent/ssl.py", line 84, in __init__ ctx = SSLContext(ssl_version)NameError: global name 'SSLContext' is not defined<Greenlet at 0x7fd6e274c4b0: <bound method SocketIOServer.wrap_socket_and_handle of <SocketIOServer at 0x7fd6e2827fd0 fileno=6 address=0.0.0.0:8000>>(<socket at 0x7fd6e2747a50 fileno=12 sock=10.0.0.41, ('10.0.0.34', 50076))> failed with NameError




Same problem here with Debian 8.2.

Same here with CentOS

Worked fine until yum update. Not sure what had caused connection to https://ajentilocation:8000 to fail.

Browser says 'SSL connection refused' type of error.

Works fine if set up with SSL turned off and going to http://ajentilocation:8000.

https connection to a website on NGINX works fine too.

Don't know what else to look into.


ajenti.log at start:

2016-01-05 21:53:24,242 INFO core.run(): Ajenti 1.2.22.13 running on platform: centos

2016-01-05 21:53:24,284 INFO sm_upstart.verify(): Disabling Upstart service manager: org.freedesktop.DBus.Error.ServiceUnknown: The name com.ubuntu.Upstart was not provided by any .service files
2016-01-05 21:53:26,141 INFO core.run(): Starting server on (u'0.0.0.0', 8000)
2016-01-05 21:53:26,150 INFO core.run(): SSL enabled: /www/.ssl/25d045c84868ee9.crt
s
2016-01-05 21:53:26,141 INFO : Starting server on (u'0.0.0.0', 8000)
2016-01-05 21:53:26,150 INFO : SSL enabled: /www/.ssl/25d045c84868ee9.crt