0
Not a bug

Некоторые пакеты имеют неудовлетворенные зависимости

Voka M 7 years ago updated by Eugene Pankov (Project coordinator) 7 years ago 3

root@server:~# wget http://repo.ajenti.org/debian/key -O- | apt-key add -

--2013-08-31 09:56:26--  http://repo.ajenti.org/debian/key

Resolving repo.ajenti.org... 108.161.187.129

Connecting to repo.ajenti.org|108.161.187.129|:80... connected.

HTTP request sent, awaiting response... 200 OK

Length: 1716 (1.7K) [application/octet-stream]

Saving to: `STDOUT'

100%[======================================>] 1,716       --.-K/s   in 0s

2013-08-31 09:56:27 (32.5 MB/s) - written to stdout [1716/1716]

OK

root@server:~# echo "deb http://repo.ajenti.org/ng/debian main main ubuntu" >> /etc/apt/sources.list

root@server:~# apt-get update && apt-get install ajenti

Hit http://repo.ajenti.org main Release.gpg

Hit http://repo.ajenti.org main Release.gpg

Hit http://repo.ajenti.org main Release

Hit http://repo.ajenti.org main Release

Ign http://repo.ajenti.org main/main Packages

Ign http://repo.ajenti.org main/main Packages

Ign http://repo.ajenti.org main/ubuntu Packages

Hit http://archive.ubuntu.com lucid Release.gpg

Hit http://archive.ubuntu.com lucid-updates Release.gpg

Hit http://archive.ubuntu.com lucid-security Release.gpg

Ign http://repo.ajenti.org main/main Packages

Hit http://archive.ubuntu.com lucid Release

Hit http://archive.ubuntu.com lucid-updates Release

Ign http://repo.ajenti.org main/main Packages

Hit http://archive.ubuntu.com lucid-security Release

Ign http://repo.ajenti.org main/ubuntu Packages

Hit http://repo.ajenti.org main/main Packages

Hit http://archive.ubuntu.com lucid/main Packages

Hit http://archive.ubuntu.com lucid/restricted Packages

Hit http://archive.ubuntu.com lucid/universe Packages

Hit http://repo.ajenti.org main/main Packages

Hit http://repo.ajenti.org main/ubuntu Packages

Hit http://archive.ubuntu.com lucid-updates/main Packages

Hit http://archive.ubuntu.com lucid-updates/restricted Packages

Hit http://archive.ubuntu.com lucid-updates/universe Packages

Hit http://archive.ubuntu.com lucid-security/main Packages

Hit http://archive.ubuntu.com lucid-security/restricted Packages

Hit http://archive.ubuntu.com lucid-security/universe Packages

Err http://mirror0.ajenti.org  Release.gpg

  Could not resolve 'mirror0.ajenti.org'

Reading package lists... Done

W: Failed to fetch http://mirror0.ajenti.org/debian/Release.gpg  Could not resolve 'mirror0.ajenti.org'

W: Some index files failed to download, they have been ignored, or old ones used instead.

Reading package lists... Done

Building dependency tree

Reading state information... Done

Some packages could not be installed. This may mean that you have

requested an impossible situation or if you are using the unstable

distribution that some required packages have not yet been created

or been moved out of Incoming.

The following information may help to resolve the situation:

The following packages have unmet dependencies:

  ajenti: Depends: python-reconfigure (>= 0.1.19) but it is not going to be installed

          Depends: python-passlib but it is not going to be installed

          Depends: python-requests (>= 0.12.0) but it is not going to be installed

          Depends: python-catcher but it is not going to be installed

E: Broken packages



Не получается установить Ajenti...

-1

Версия ОС?

apt-get install python-passlib?

Linux wotedit 2.6.32-042stab079.4 #1 SMP Thu Jul 18 18:57:29 MSK 2013 x86_64 GNU/Linux

Ubuntu 10.04.4 LTS

Welcome to Ubuntu!

 * Documentation:  https://help.ubuntu.com/

Last login: Sat Aug 31 12:02:54 2013 from 217.118.93.99

root@wotedit:~# apt-get install python-passlib

Reading package lists... Done

Building dependency tree

Reading state information... Done

Some packages could not be installed. This may mean that you have

requested an impossible situation or if you are using the unstable

distribution that some required packages have not yet been created

or been moved out of Incoming.

The following information may help to resolve the situation:

The following packages have unmet dependencies:

  python-passlib: Depends: python (>= 2.6.6-7~) but 2.6.5-0ubuntu1 is to be installed

E: Broken packages


Пришлось поставить ubuntu 12.04 x86

Проблема решена.