0
Færdig

ability to override client_max_body_size

Arthur Wiebe 6 år siden opdateret af Eugene Pankov (Project coordinator) 6 år siden 6
Currently the nginx client_max_body_size setting is in proxy.conf and it's set to a default of 10m. Which is probably fine for a default.

But I host mostly wordpress sites where they are uploading podcasts, and 10m does not work so well for that.

I can override it on a per/web site basis but I'd like to be able to override it on a global basis which is currently not possible because any time I update Ajenti, proxy.conf is overwritten and it's set back to 10m.
GOD, JEG ER TILFREDS
Tilfredshedsangivelse af Arthur Wiebe 6 år siden
Under vurdering
You should be able to override global client_max_body_size through Websites > Advanced > Custom configuration.
Yes that's on a per-website basis. I would like to be able to override it on a global basis so that it applies to all the web sites.
Sorry, I missed that. However there's a "custom top-level configuration" field, whose content goes into NGINX's http {} block and applies to everything.
If I place that setting under the "custom top-level configuration" when I restart the nginx service I get the following error:
[emerg] 22847#0: "client_max_body_size" directive is duplicate in /etc/nginx/conf.d/websitename.conf

Because that setting already exists in proxy.conf it can only be overridden in a sub-config for example under the server {} section.
I'm not sure how this setting ended up in proxy.conf, but I sure didn't intend to put it there. Fix released.

Kundesupport af UserEcho