+1

I need help with ssl!

Niriter 6 months ago • updated by Glaumy - Glaucomys Dragón 2 months ago 1

I need help with ssl(https) ajenti, after not good quick instalation ajenti with this code:

curl https://raw.githubusercontent.com/ajenti/ajenti/master/scripts/install.sh | sudo bash -s -

i install another method

wget http://repo.ajenti.org/debian/key -O- | sudo apt-key add -


echo "deb <a class="vglnk" href="http://repo.ajenti.org/ng/debian" rel="nofollow">http://repo.ajenti.org/ng/debian</a> main main ubuntu" | sudo tee -a /etc/apt/sources.list


sudo apt-get update && sudo apt-get install ajenti


sudo service ajenti restart


i have error in chrome and not only in chrome:


 SSL_ERROR_RX_RECORD_TOO_LONG


How i can disable ssl in configs, or how fix this error???


but in http (http://localhost:8000/) i see this text:

Invalid URL


Oi.
I need to bump this. I have the same problem on an ubuntu 16.04 hyper-v server. I had the problem before, too. I installed Ajenti 2 first - which worked except from telling me "not a superuser", found out I wanted Ajenti 1.x, unsuccessfully uninstalled Ajenti 2, then installed Ajenti 1.x, completely uninstalled everything and reinstalled Ajenti 1.x, which did not work (SSL_ERROR_RX_BLAH as above). Overinstalling Ajenti V did not change anything, so I un- and reinstalled everything several times but could not change anything.

For all the initial installs and for most reinstalls, I used the quick cmds from the documentation that is linked on the product pages of ajenti.org.

Feel free to request any problem related logs or information you need to solve my problem.