0

Erro 502: ajenti-v-php-fcgi-0.sock failed

Paul Deng 4 years ago updated 4 years ago 7

Hi Ajenti,


I got error 502 when I visit the Wordpress site created in Ajenti.


--/var/log/nginx/exampledomain.err.log:

2016/04/15 04:52:19 [error] 1109#0: *6174 connect() to unix:/var/run/ajenti-v-php-fcgi-exampledomain-php-fcgi-0.sock failed (11: Resource temporarily unavailable) while connecting to upstream, client: ipaddress, server: exampledomain, request: "POST /xmlrpc.php HTTP/1.1", upstream: "fastcgi://unix:/var/run/ajenti-v-php-fcgi-exampledomain-php-fcgi-0.sock:", host: "ipaddress"



--/var/log/upstart/php5-fpm.log

[15-Apr-2016 04:54:11] WARNING: [pool exampledomain-php-fcgi-0] seems busy (you may need to increase pm.start_servers, or pm.min/max_spare_servers), spawning 8 children, there are 0 idle, and 4 total children[15-Apr-2016 04:54:12] WARNING: [pool exampledomain-php-fcgi-0] server reached pm.max_children setting (5), consider raising it


Ubuntu 12.04

Php and fpm 5.6.20


Any one getting the same error?


Thanks a lot.

















Hey Paul!


The last sentence should be the answere for your problem :P

"server reached pm.max_children setting (5), consider raising it"


Could u please Post the numbers / settings for these things, listed in "/etc/php5/fpm/pool.d/www-conf"


pm =

pm.max_children =

pm.start_servers =

pm.min_spare_servers =

pm.max_spare_servers =

;pm.process_idle_timeout =

;pm.max_requests =


AND if some things start with ";" like i did with 2 things^^

Hi Pierre,


Thanks for your response.


I am using default settings:

pm = dynamic

pm.max_children = 5

pm.start_servers = 2

pm.min_spare_servers = 1

pm.max_spare_servers = 3

;pm.process_idle_timeout = 10s

;pm.max_requests = 500


This is a tiny personal stie, no heavy traffic at all. Also, I have 200MB ram available.


Thanks again.



Hi Paul,


can you tell me if this always happens, if you want to open your website, or does it only happen some times ?


In the Ajenti Panel, there is a widget, to show how much Ram u are using.

To tell a more accurate memory usage, could you install "apt-get install htop" after that use the command "htop" and after that look on memory usage. After that u can close htop with "ctrl+c".


It could be that Ajenti-v will take about 250 mb of your Ram (With all services enabled like MySQL and such things)


Regards Pierre

Hi Pierre,


There are 3 low traffic WP sites running on this !GB ram VPS, only this particular 1 site always has this issue.


I have set the

PHP.ini

memory_limit = -1 (unlimited)


The htop shows 400/995MB, but the issue is still there.


Thanks a lot.

Hi Paul,


If you create a new "Webspace" in Ajenti and move your WP folder so it uses the new Webspace instead, does the Error still happen ?


Regards Pierre

Hi Pierre,


I think it is a memory resource issue.


I have set the "memory_limit=-1" in php.ini and "pm=ondemand" in php-fpm.conf. It seems issue is now fixed for my low traffic websites.


Thanks for you time.