0
Not a bug

Manual/SSH password reset

Zach Lym 4 years ago • updated by claudemacho 5 months ago 10

The instructions on this page did not work for me.


1) sudo nano /etc/ajenti/config.json

{

"users": {

"root": {

"configs": {

"ajenti.plugins.notepad.notepad.Notepad": "{\"bookmarks\": []}",

"ajenti.plugins.fm.fm.FileManager": "{\"root\": \"/\"}",

"ajenti.plugins.terminal.main.Terminals": "{\"shell\": \"sh -c $SHELL || sh\"}",

"ajenti.plugins.dashboard.dash.Dash": "{\"widgets\": [{\"index\": 0, \"config\": null, \"container\": \"0\", \"class\": \"ajenti.plugins.dashboard.welcome.WelcomeWidget\"}]}"

},

"password": "password",

"permissions": []

},

"indolering": {

"configs": {},

"password": "password",

"permissions": []

}

},

"bind": {

"host": "0.0.0.0",

"port": 8000

},

"authentication": true,

"ssl": {

"enable": true,

"certificate_path": "/etc/ajenti/ajenti.pem"

},

"enable_feedback": true,

"installation_id": 6217

}

2) sudo service ajenti restart

Both operations completed successfully.

Yes, that's exactly what I did.  I tried it for my "indolering" user first.  When that failed to produce results, I changed it for root as well.

But which user did you login as after that?

Same problem here.  The faq (correct link is http://docs.ajenti.org/en/latest/man/faq.html#i-fo... doesn't work.

I'm using version 1.2.21.4 according to the below.

root:~# /usr/bin/ajenti-panel -v
02.06.2014 11:46 ajenti-panel:105 INFO Using config file /etc/ajenti/config.json
02.06.2014 11:46 ajenti-panel:129 INFO Ajenti starting in foreground
02.06.2014 11:46 registry.py:247 INFO registered crypt handler 'sha512_crypt': <class 'passlib.handlers.sha2_crypt.sha512_crypt'>
02.06.2014 11:46 compat.py:20 DEBUG Popen: git describe --tags 2> /dev/null
02.06.2014 11:46 compat.py:20 DEBUG Popen: ['lsb_release', '-sd']
02.06.2014 11:46 core.py:60 INFO Ajenti 1.2.21.4 running on platform: debian

It might not work if a) you didn't restart Ajenti b) you have password sync (OS/LDAP/AD) enabled
Thanks for the reply.  I did restart, and I don't have LDAP/AD sync. hmm, I might have had OS sync enabled.

I fixed it by copying an unmodified config file from another server.
+1
If you had OS sync, you could just use passwd to change password of respective user. Another (insecure) option is to disable auth temporarily.

perdi minha senha como posso recuperar