0
Not a bug

Error Ajenti

Guillaume Reynaud 4 years ago • updated by anason printwork 3 weeks ago 9
Hello,
excuse me for my bad english.

I often error Could not bind to (U'0 .0.0.0 '), 8000) usually follows an update of Ajenti.
The service may not start properly. The only way I've found to regain access to the web is to restart the server interface.
Is there a less drastic solution.
Thank you. guillaume.

Answer

Answer
Hi,

Where do you see this error? In the logs, or in the console?
Answer
Hi,

Where do you see this error? In the logs, or in the console?
Im getting this error also.

I see this when I enter 
sudo ajenti-panel -v
Im not able to login via https://...:8000 it returns time out.

It seams that python is listening to this port:
tcp 0 0 0.0.0.0:8000 0.0.0.0:* LISTEN 2658/python 


+1
Under review
Do you have a firewall configured? See this: http://support.ajenti.org/topic/349866-installing-... on how to open the Ajenti port temporarily.

Also check that you have only one Ajenti process: ps aux | grep ajenti
It was the firewall. Thanks a lot Eugene! Great support!
if you use Custom top level configuration, or define server_name manualy, this why you get thats error
check your /etc/nginx/conf.d/yoursite.conf
for two server block , and two server_name
if there is two of them, delete the one your dont want

I have done following steps in ubuntu 14.04 server LTS, i can now access the panel.

1) run this commands:

apt-get install python-pip pip install passlib

source: http://support.ajenti.org/topic/222149-need-to-pip-install-passlib/
2) in /etc/ajenti/config.json i changed
"SSL":{ enabled:true, ... }
to this
"SSL":{enabled:false, ...}
3) restart ajenti service
4) access ajenti with following address

http://myserveraip_address:8000

Hi, i am having problem with error could not bind to port 8000.


i upgraded ubuntu 16.04 and installed SSL and now can't access the port already.


i have checked sudo netstat -tlnp | grep 8000 and it seems there is phyton using this port. I killed the process but still unable to get ajenti to access this port.


I tried to use the above step but still fail.


Anybody can help?